Closed Bug 1080361 Opened 5 years ago Closed 5 years ago

DOMException InvalidStateError when setPointerCapture was invoke on element from alien document tree

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: alessarik, Assigned: alessarik)

References

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140825202822

Steps to reproduce:

Test assertion 13.4



Expected results:

If the Element on which this method is invoked does not participate in its ownerDocument's tree, throw an exception with the name InvalidStateError.
Component: Untriaged → DOM: Events
Product: Firefox → Core
Add check for correct detecting element in DOM tree in setPointerCapture function
Attachment #8502459 - Flags: review?(bugs)
Attachment #8502459 - Flags: feedback?(mbrubeck)
Blocks: 1042108
OS: Windows 8 → All
Hardware: x86_64 → All
Attachment #8502459 - Flags: feedback?(mbrubeck) → feedback+
Comment on attachment 8502459 [details] [diff] [review]
invalid_state_error_ver1.diff

A test would be nice (and since this is a tiny change, you could just add the test to some existing test file).
Attachment #8502459 - Flags: review?(bugs) → review+
+ Test. Several tests for check several exception in setPointerCapture function
Attachment #8504664 - Flags: review?(bugs)
Attachment #8504664 - Flags: feedback?(mbrubeck)
Attachment #8504664 - Flags: review?(bugs) → review+
+ Changes: Repair wrong variable name
Attachment #8504664 - Attachment is obsolete: true
Attachment #8504664 - Flags: feedback?(mbrubeck)
Attachment #8504768 - Flags: review?(bugs)
Attachment #8504768 - Flags: feedback?(mbrubeck)
Attachment #8504768 - Flags: review?(bugs) → review+
Attachment #8504768 - Flags: feedback?(mbrubeck) → feedback+
If nobody have objections, I put checkin flag.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a542486a0852
https://hg.mozilla.org/mozilla-central/rev/4401c5453e50
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.