nsEventQueueImpl destructor uses getService to shutdown; suggest using WeakRef

VERIFIED DUPLICATE of bug 134723

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 134723
17 years ago
16 years ago

People

(Reporter: David Epstein, Assigned: dougt)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
this is causing warning msg when shutting down Mozilla. See bug 107391).
reproduced in 10/27 debug mozilla build.
1. Set break points in nsWarning messages in nsComponentManager.cpp;
nsComponentManagerImpl::GetService() and
nsComponentManagerImpl::GetServiceByContractID() (currently lines 1750 & 2075).
2. Launch Mozilla with F5.
3. Quit Mozilla.
4. Press F5 until you see stack trace including destructor for
nsEventQueueImpl()
5. Doubleclick on line above ~nsEventQueueImpl():
nsEventQueueImpl::NotifyObservers(const char * 0x10110b54) line 220 + 30 bytes
Result: Creates nsIObserverService object by calling do_GetService() to shutdown
nsEventQueueImpl service. 
Suggest registering a weakReference.
(Reporter)

Updated

17 years ago
Blocks: 107391
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Updated

16 years ago
No longer blocks: 107391

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 134723 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
-> vrfy.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.