Closed Bug 1080703 Opened 5 years ago Closed 5 years ago

Switch Mozilla Discourse to Amazon SES

Categories

(Participation Infrastructure :: MCWS, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: yousef, Assigned: yousef)

Details

(Whiteboard: [approved][2014/10/21 @ 10:00pm UTC])

We're reaching our limit on Mandrill, need to move to SES.
Assignee: nobody → yousef
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1080924
Reopening since this is for discourse.mozilla-community.org.

Planned for next maintenance.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [next maintenance]
Whiteboard: [next maintenance] → [needs CAB review]
What's needed to get this going? Both Discourse instances need to switch as we're going to be cutting it close this month on Mandrill.
Flags: needinfo?(mzeier)
When is the next maintenance planned? What's the impact to users?

What's the change look like? How do you test? How do you roll back?
Flags: needinfo?(mzeier)
(In reply to matthew zeier [:mrz] from comment #4)
> When is the next maintenance planned?
A week from now works for me.

(In reply to matthew zeier [:mrz] from comment #4)
> What's the impact to users?
Worst case scenario is that email from SES ends up in spam but from my testing before this wasn't the case.

(In reply to matthew zeier [:mrz] from comment #4)
> What's the change look like? How do you test?
No user-facing changes, only replacing information in the config file. Discourse allows us to send test emails which I can use to test if it's been configured correctly.

(In reply to matthew zeier [:mrz] from comment #4)
> How do you roll back?
Put the mandrill information back into the app.yml file.
Whiteboard: [needs CAB review] → [approved][2014/10/21 @ 10:00pm UTC]
Both instances have been moved over and tested to ensure they work.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED

Bulk move of bugs

Component: Community IT: Infrastructure → MCWS
Product: Infrastructure & Operations → Participation Infrastructure
You need to log in before you can comment on or make changes to this bug.