Closed Bug 1080845 Opened 6 years ago Closed 5 years ago

22% OSX 10.8 TP5 Scroll regression on inbound (v.35) Oct 7 from push 81eafec98b48

Categories

(Core :: Graphics, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox35 + wontfix

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [talos_regression])

on graph server you can see a regression oct 7 in osx 10.8 tp5 scroll:
http://graphs.mozilla.org/graph.html#tests=%5B%5B323,63,24%5D,%5B323,63,21%5D%5D&sel=none&displayrange=7&datatype=running

oddly enough around the same time we had a win on osx 10.6, but that doesn't seem to be related to this patch.

Here is the push:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=81eafec98b48

I haven't been able to get retriggers to work for the last couple of hours (yay infrastructure issues).  

here is a link to the tp5 scroll test:
https://wiki.mozilla.org/Buildbot/Talos/Tests#tp5o_scroll
this is on beta now

On aurora we saw a slight regression when this made it to Aurora on Oct 13th, then of course this test regression again when v.36 moved to aurora.

But on beta, we don't show a 22% increase, more like a 5%:
http://graphs.mozilla.org/graph.html#tests=%5B%5B323,53,24%5D,%5B323,52,24%5D%5D&sel=1412993539522.4814,1418306174758.2134,0.3688524590163933,1.5983606557377046&displayrange=90&datatype=running
Probably something we should do about this, but I'm not sure how Matt's doing for time, or if he knows how to fix it - Matt, let me know and I can find somebody else if this would take too long with your current priorities.
Flags: needinfo?(matt.woodrow)
I believe I attempted to reproduce this locally and couldn't see any regression, though I also thought I posted a comment on the bug about doing so.

Milan, if anyone can reproduce this locally then it's probably worth a quick look (visible region changes shouldn't be too hard to investigate), but I doubt it's worth much more time investment than that.
Flags: needinfo?(matt.woodrow)
Looks like a decent attempt was made to reproduce but without someone being able to successfully do so, we don't have anything actionable for 35, wontfixing.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.