bugzilla mails support support no non-ASCII

RESOLVED DUPLICATE of bug 714724

Status

()

Bugzilla
Email Notifications
RESOLVED DUPLICATE of bug 714724
4 years ago
4 years ago

People

(Reporter: bjoern, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 2014092300

Steps to reproduce:

get mails with non-ASCII caracters like "o with dots above" (ö).


Actual results:

the characters are not displayed correctely cause no charset was deined in the mail, so the client (mutt in my case) could only "guess" what that non-ASCII character might be. Guessing charsets is obviously not a good idea though ;-)


Expected results:

the right charset should be given in the mail header and in the mail attachment headers. (e.g. content-type: text/html; charset=utf8).

As bugzilla only has a utf8 or non-utf8 mode, e.g. no other charset can be defined explicitly, we can always set utf8 as charset in mails, as ASCII is a complete subset of UTF-8

Patch to follow...
(Reporter)

Comment 1

4 years ago
Created attachment 8503049 [details] [diff] [review]
0001-bug-1081045-create-notification-mails-with-the-right.patch
(Reporter)

Updated

4 years ago
Version: unspecified → 4.4.6

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 714724
You need to log in before you can comment on or make changes to this bug.