Closed Bug 1081154 Opened 5 years ago Closed 5 years ago

Loop direct calls should attempt to call phone numbers as well as email addresses

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
2

Tracking

(firefox33 unaffected, firefox34+ verified, firefox35+ verified, firefox36 verified)

VERIFIED FIXED
mozilla36
Iteration:
36.1
Tracking Status
firefox33 --- unaffected
firefox34 + verified
firefox35 + verified
firefox36 --- verified
Blocking Flags:
backlog Fx34+

People

(Reporter: standard8, Assigned: standard8)

Details

(Whiteboard: [loop-uplift][loop-outcall1])

Attachments

(1 file, 1 obsolete file)

Currently, when calling a contact we only use any email addresses for a contact - in the list of ids we send to the server.

We need to additionally include any phone number information that we have - import contacts have phone numbers already.

When forming the list of phone numbers we should strip non-numbers & and leave a plus at the start.
Target Milestone: --- → mozilla35
backlog: --- → Fx34+
Mark -- I believe we need to prioritize this one bug over the standalone work if we want to get it into Fx34.  My understanding is that this would be a relatively small patch.  Is this something we could have soon?
Flags: needinfo?(standard8)
Simple patch that adds in phone numbers to the list of ids that are attempted to be called for a contact.

Tested on desktop with emails, and on FxOS with the Hello app signed in with a phone number.
Attachment #8506050 - Flags: review?(mdeboer)
Flags: needinfo?(standard8)
Updated patch to include stripping of unnecessary characters from phone numbers.
Attachment #8506050 - Attachment is obsolete: true
Attachment #8506050 - Flags: review?(mdeboer)
Attachment #8506080 - Flags: review?(mdeboer)
Comment on attachment 8506080 [details] [diff] [review]
Loop direct calls should attempt to call phone numbers as well as email addresses.

Review of attachment 8506080 [details] [diff] [review]:
-----------------------------------------------------------------

/me like!

Thanks Mark.
Attachment #8506080 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/integration/fx-team/rev/2e896ba5d24f
Iteration: --- → 36.1
Points: --- → 2
Target Milestone: mozilla35 → mozilla36
Comment on attachment 8506080 [details] [diff] [review]
Loop direct calls should attempt to call phone numbers as well as email addresses.

Approval Request Comment
[Feature/regressing bug #]: Part of call handling for Firefox Hello
[User impact if declined]: Users won't be able to call Firefox OS mobiles that are signed into the Hello app using phone numbers.
[Describe test coverage new/current, TBPL]: Tested locally, has unit tests to cover additions, landed on fx-team, should merge to nightly soon.
[Risks and why]: Low, existing tests cover making sure the email addresses are still callable, extension for phone numbers also tested.
[String/UUID change made/needed]: None
Attachment #8506080 - Flags: approval-mozilla-beta?
Attachment #8506080 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/2e896ba5d24f
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
[Tracking Requested - why for this release]:
Tracking for release, See Comment 6
Tracking for uplift see Comment 6
Untracking for QE verification since this appears to have pretty good test coverage already. Please needinfo me to request manual verification.
Flags: qe-verify-
Tested and works on Nightly 10/18; Windows and Linux
Also note I called a Hello app on Flame using it
Comment on attachment 8506080 [details] [diff] [review]
Loop direct calls should attempt to call phone numbers as well as email addresses.

Thanks for testing jesup. Approved for Aurora. If everything goes well with your testing on Aurora on Sunday, we'll get this uplifted for beta2.
Attachment #8506080 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tested and good on Aurora nightly build; windows and linux.
Comment on attachment 8506080 [details] [diff] [review]
Loop direct calls should attempt to call phone numbers as well as email addresses.

Previously approved offline. Adding approval to the bug.
Attachment #8506080 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Changing this to qe-verify+ since it's a blocker for release.

Florin, please make sure this gets tested as part of Beta 2, assuming it uplifts in time.
Flags: qe-verify-
Flags: qe-verify+
Flags: needinfo?(florin.mezei)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #18)
> Florin, please make sure this gets tested as part of Beta 2, assuming it
> uplifts in time.
I was blocked in testing this on Fx OS 2.0/188 - couldn't pass over the first screen in the Hello app.
Nothing happens when I click on the 'use phone number' button, just a short "authenticating".
(In reply to Paul Silaghi, QA [:pauly] from comment #19)
> I was blocked in testing this on Fx OS 2.0/188 - couldn't pass over the
> first screen in the Hello app. Nothing happens when I click on the 
> 'use phone number' button, just a short "authenticating".

Tony, is this a known issue with the FxOS client?
Flags: needinfo?(tchung)
This is caused by Bug 1086880 in v188

Per Mariateo, installing *2* SIMs will get you past the bug.

ferjm gave this workaround as well:

adb root
adb shell stop b2g
adb remount
adb shell rm -r /system/b2g/distribution/bundles
adb shell start b2g ----- (if this doesn't work, do an "adb reboot" instead)

I tried the workaround with b2, and was able to call the fxos phone by number
yep, what jesup said.  that bug is now blocking 2.1.   you can retry this against v180 and see if it works.
Flags: needinfo?(tchung)
(In reply to Randell Jesup [:jesup] from comment #21)
> I tried the workaround with b2, and was able to call the fxos phone by number
Marking verified in 34b2
Status: RESOLVED → VERIFIED
Flags: needinfo?(florin.mezei)
You need to log in before you can comment on or make changes to this bug.