After flashing new KK image I can't update my flame

RESOLVED DUPLICATE of bug 1073399

Status

Firefox OS
AudioChannel
RESOLVED DUPLICATE of bug 1073399
3 years ago
3 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8503225 [details]
download_flame.log.3.txt

I could not figure out which component.

I sometimes get a message saying that the update failed to download (it shows on the screen after a reboot) - "There was an error while downloading the updates".

However, what I see most is that after the unzipping update stage finishes the state of that update goes back to say that I can download an update.

I have attached a logcat in hopes that it can help figure this out.

I'm on 2.10.0-prerelease, 34.0a2, 201410060000205, update channel aurora.
Please provide |adb shell df| output, I feel it's just a free space issue.
(Reporter)

Comment 2

3 years ago
armenzg-thinkpad buildbot-configs hg:[production!] $ adb shell df
Filesystem               Size     Used     Free   Blksize
/dev                   149.6M   132.0K   149.5M   4096
/sys/fs/cgroup         149.6M    12.0K   149.6M   4096
/mnt/asec              149.6M     0.0K   149.6M   4096
/mnt/obb               149.6M     0.0K   149.6M   4096
/system                354.2M   272.9M    81.2M   4096
/data                    2.0G    93.3M     1.9G   4096
/cache                  70.8M    22.8M    48.0M   4096
/persist                 4.9M     4.1M   848.0K   4096
/firmware               64.0M    31.4M    32.5M   16384
/storage/sdcard1         3.6G     2.0M     3.6G   4096
/storage/sdcard          3.8G     2.9M     3.8G   4096
/mnt/media_rw/sdcard     3.8G     2.9M     3.8G   4096
/mnt/media_rw/sdcard1     3.6G     2.0M     3.6G   4096
(Reporter)

Comment 3

3 years ago
root@flame:/system # du -d 1                                                 
8	./lost+found
176784	./b2g
24448	./bin
8976	./etc
43688	./fonts
108896	./lib
38000	./media
12672	./tts
38856	./usr
91304	./vendor
3752	./xbin
547416	.
(Reporter)

Comment 4

3 years ago
I think the minimum we could fix in here is to not download a new update without checking remaining free space under /system.
There's no need to get us into an infinite loop and we could notify the user how to proceed (e.g. file a bug in X and attach Y).
(Reporter)

Comment 5

3 years ago
I don't know why I had /system/media [1], however, after deleting it I got close to 100MB free space on /system [2] and managed to update.

I also pasted the output of a flame that was flashed yesterday [3].

[1]
armenzg-thinkpad buildbot-configs hg:[production!] $ adb shell ls -al /system/media
drwxr-xr-x root     root              2014-09-04 03:53 audio
-rw-r--r-- root     root      9835252 2014-09-04 03:53 bootanimation.zip
root@flame:/system/media # ls
audio
bootanimation.zip
root@flame:/system/media # ls audio/                                           
alarms
notifications
ringtones
ui

[2]
armenzg-thinkpad buildbot-configs hg:[production!] $ adb shell df /system
Filesystem               Size     Used     Free   Blksize
/system                354.2M   254.9M    99.2M   4096

[3]
flash@FlashStation50:~$ adb shell du -d 1 /system
8	/system/lost+found
175360	/system/b2g
9896	/system/bin
5752	/system/etc
57664	/system/fonts
51696	/system/lib
12672	/system/tts
38720	/system/usr
90168	/system/vendor
442024	/system

Comment 6

3 years ago
OK, if the free space in /system is the issue, it's a dupe of bug 1073399. Thanks for the detailed data!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1073399
You need to log in before you can comment on or make changes to this bug.