Closed Bug 1081293 Opened 7 years ago Closed 7 years ago

Assertion failure in ServiceWorkerContainer::RemoveReadyPromise()

Categories

(Core :: DOM: Workers, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla38

People

(Reporter: mccr8, Assigned: nsm)

References

Details

Attachments

(1 file)

Running locally, I'm hitting the assertion MOZ_ASSERT(swm) in this method.  Is that expected?  This is just running e10s mochitests with some patches that keep us from crashing in shutdown.  IIRC, this was happening inside the shutdown CC.  I just changed the assert to a null check and it seems okay.
Assignee: nobody → nsm.nikhil
Status: NEW → ASSIGNED
Comment on attachment 8553927 [details] [diff] [review]
Silently ignore lack of ServiceWorkerManager when shutting down ServiceWorkerContainer

Review of attachment 8553927 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/workers/ServiceWorkerContainer.cpp
@@ +55,5 @@
>    nsCOMPtr<nsPIDOMWindow> window = GetOwner();
>    if (window) {
>      nsCOMPtr<nsIServiceWorkerManager> swm =
>        mozilla::services::GetServiceWorkerManager();
> +    if (!swm) {

Maybe just write a comment...
Attachment #8553927 - Flags: review?(amarchesini) → review+
https://hg.mozilla.org/mozilla-central/rev/e3d924b6797f
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Duplicate of this bug: 1122689
You need to log in before you can comment on or make changes to this bug.