Closed Bug 108147 Opened 19 years ago Closed 19 years ago

Download dialog say "KB" while some SI correct form would be "kB"

Categories

(Core Graveyard :: File Handling, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: jst, Assigned: law)

References

(Blocks 1 open bug)

Details

'k' is the unit for kilo, 'K' is not.
I believe it's been decided to use KB. See bug 94961, bug 106618 and references
in those. The correct computer term seems to be be KiB, but it's a new standard
and not in use. KB is close though and less confusing than kB, imo. Lowercase k
would indicate exactly 1000.
wontfix
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
vrfy wontfix
Status: RESOLVED → VERIFIED
Summary: Download dialog sez "KB" when it should say "kB" → Download dialog say "KB" while some SI correct form would be "kB"
I still think this is bogus. Using 'K' to mean kilo in computer terms (2^10) to
not confuse with the kilo that means 1000 while still using 'M' to represent
mega in computer terms (2^20), when that really does mean 1000,000 (same goes
for GB, TB, ...). I don't get it. I'm not convinced that this is not a bug, but
reading the posts in the other bug referenced here, I won't bother fighting this.
*** Bug 117697 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 415999
I do not know exactly how this is in the code, but if the base is 1024 then it should be KiB/s rather than kB/s(as defined by the IEC).
If it's base 10, then kB/s is fine(and should indeed replace KB/sec).
(In reply to comment #7)
> I do not know exactly how this is in the code, but if the base is 1024 then it
> should be KiB/s rather than kB/s(as defined by the IEC).
> If it's base 10, then kB/s is fine(and should indeed replace KB/sec).
> 

see bug 106618
Duplicate of this bug: 423189
This has actually be changed for the en-GB localisation. Although, arguably because of the European Harmonisation Document it's wrong because it should be KiB as per bug 420710
Duplicate of this bug: 451042
Duplicate of this bug: 680801
Blocks: 420710
Notice about:cache still uses KiB. Is that a problem?
Duplicate of this bug: 789912
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.