Firefox freezes while attempting to modify nvdrssel.bin

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: obrufau, Unassigned)

Tracking

35 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8503631 [details]
Screenshot of Comodo notification

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141011030203

Steps to reproduce:

Sometimes, when a new page is loading, my Comodo Firewall Defense+ warns me Firefox is attempting to modify the contents of "C:\WINDOWS\system32\nvdrssel.bin".

It doesn't matter if I allow it or block it.


Actual results:

Firefox freezes (using 0% CPU).


Expected results:

Firefox shouldn't freeze.
And probably, Firefox shouldn't attempt to modify "C:\WINDOWS\system32\nvdrssel.bin".

Before today, Firefox never attempted to modify that file, and there have been 3 attempts. So I think the culprit is today's Nigthly update (Nightly 35.0a1 2014-10-11).
(Reporter)

Comment 1

4 years ago
Created attachment 8503645 [details]
Demo

This problem was happenning randomly on some sites.

But I have found a pdf which always produces it: the attached demo.

Nigthly 2014-10-10 doesn't have this problem.

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=50b689feab5f&tochange=f74ad36bb97b
(Reporter)

Comment 3

4 years ago
I have experimented a bit, and it seems for most people Firefox won't freeze.

Firefox tries to modify those:
 - "C:\WINDOWS\system32\nvdrssel.bin"
 - "\SYSTEM\ControlSet001\Services\Eventlog\Application\NVIDIA OpenGL Driver\TypesSupported"
 - "\SYSTEM\ControlSet001\Services\Eventlog\Application\NVIDIA OpenGL Driver\EventMessageFile"

If I allow or block that very fast, Firefox attempts to modify the next one.
But if I wait a bit for any of them, Firefox freezes.

Therefore, it's likely that people who don't have Comodo firewall (or have it configured to allow/block Firefox to modify those above) won't have any problem.

However, I still think this should be fixed. If Firefox freezes if it can't access that file or registry entries instantly, it probably means that it will also freeze on a computer with a very slow hard disk.
In fact, I had never seen any program which froze because of Comodo asking me to allow or block it.
Component: Untriaged → Untriaged
Product: Firefox → Core
Hi Reporter,

Since Bug 1066280 was fixed and I don't have Comodo Firewall on my environment, could you please try to reproduce your issue on the latest release(43.0.1) and the latest Nightly(https://nightly.mozilla.org/) and provide the results? When doing this, please use a new clean Firefox profile, maybe even in safe mode, as some of these issues may be caused by third party installed add-ons or custom settings (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Cipri.
Flags: needinfo?(obrufau)
(Reporter)

Comment 5

3 years ago
I removed that file and registry keys from the Comodo whitelist, but even then I don't get these warnings anymore, neither on Nightly nor Release.

So I can't no longer reproduce this. Marking as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(obrufau)
Resolution: --- → WORKSFORME
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.