[SMS] Delayed reaction from entering settings to message settings from SMS

RESOLVED DUPLICATE of bug 1007600

Status

RESOLVED DUPLICATE of bug 1007600
4 years ago
4 years ago

People

(Reporter: jthomas, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-flame-test-run-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8503700 [details]
logcat_20141011_1719.txt

[Location](Concise statement of the issue)

Description: There is a delay from selecting settings in SMS from normal settings to message settings.

Repro Steps:
1. Update a Flame to 20140902040205
2. Open SMS app
3. Tap the top right button to open the menu (note: you need to wait that the first panel is loaded for the menu to work)
4. Select "settings"

Actual: The Settings menu is displayed for more than a few seconds and then the page will change to the Messaging Settings. 

Expected: The "messaging" settings is  quickly displayed.

Environmental Variables:
Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Repro frequency: 100%
See attached: Logcat
Video: https://www.youtube.com/watch?edit=vd&v=BNqfQb94keM
(Reporter)

Comment 1

4 years ago
This issue DOES occur on the Flame 2.1 KK (319mb)


Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result: Delayed reaction from entering the settings to message settings from SMS
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [2.1-flame-test-run-3]
(Reporter)

Updated

4 years ago
Blocks: 1050402
I think we already have an issue for this, don't you think Arthur?
Component: Gaia::SMS → Gaia::Settings
Flags: needinfo?(arthur.chen)
Yes, this is the current limitation of settings app. The issue will be fixed along with bug 1007600.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(arthur.chen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1007600
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.