Show battery charge parcentage on the battery icon

RESOLVED DUPLICATE of bug 810500

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 810500
3 years ago
3 years ago

People

(Reporter: Ashickur Rahman, Unassigned)

Tracking

({feature})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
>> Feature Request Title:
Show battery charge parcentage on the battery icon

>> Description of feature, or problem to be solved
Each time when I need to check the battery level, I have to go to settings, scroll down to the bottom and check the battery level. It would be nice if we can show the battery charge level in the battery icon itself.

>> Impact of implementing the feature/solution
If we can do it, we don't need to go to settings and scroll to the bottom every time. It will save few time.

>> Impact of NOT implementing the feature/solution
It will kill time for the user.

>> Date required
UX, what are your thoughts on either having a setting to enable the user to show % or showing it be default?
Flags: needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Comment 2

3 years ago
As a user, I love to have a setting for it.
Redirecting to Peter La (owner of iconography). Flagging myself as a reminder as well.

What do you think?  We currently show a fill that allows the user to approximate the amount of battery life left.  An option to turn on the % could work, let's talk about it when you're back from vacation.
Flags: needinfo?(pla)
Flags: needinfo?(epang)

Updated

3 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(epang)

Comment 4

3 years ago
Hey Eric/Peter/Ashickur,

I think this would be beneficial to have as an option in Settings - however, we just need to keep in mind that, due to the small RocketBar text field in the top left corner, we're quite a bit more strapped for space than other OSes.  Eric, it would be a good idea to mock this up and see what kind of space we have left for other indicators.
Flags: needinfo?(pla)
Dupe of bug 810500
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810500
You need to log in before you can comment on or make changes to this bug.