change 'app domain' in details to 'Origin'; and (for privileged apps) show it above the fold

VERIFIED FIXED in 2014-10-28

Status

Marketplace
Reviewer Tools
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Adrian Crespo, Assigned: mat)

Tracking

2014-Q4
2014-10-28
Points:
---

Details

(Whiteboard: [repoman])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141007073543

Steps to reproduce:

I was reviewing this app:
https://marketplace.firefox.com/reviewers/apps/review/navitime


Actual results:

The developer said:
<--------------------->
This application has the login function.
The login function, cookie is required.
In order to use the cookie, setting of the origin is required.
To the setting of the origin, must be "type": "privileged".

cf.
App manifest origin
https://developer.mozilla.org/en-US/Apps/Build/Manifest#origin

HTTP access control Access-Control-Allow-Origin
https://developer.mozilla.org/en-US/docs/Web/HTTP/Access_control_CORS#Access-Control-Allow-Origin
<--------------------->




Expected results:

It should use an explicit permission in order to set the origin.

Or at least, there should be a warning or message in the "Requested Permissions" section:
http://i.imgur.com/eCx2PP2.png
The screenshot shows it's a privileged app.  We're triaging this, but we're not sure what this bug is asking for.  Andrew - is this something you've encountered?
Flags: needinfo?(awilliamson)
(Reporter)

Comment 2

4 years ago
It is privileged because the owner set it, but there is no easy way for a reviewer to identify it quickly :\
its shown under app details, but hidden under the 'more' fold by default.  I'm not 100% what problem we're trying to avoid though.
Flags: needinfo?(awilliamson) → needinfo?(madrid.crespo)
(Reporter)

Comment 4

4 years ago
After explaining my idea to [:eviljeff], he told me that It would be better to simply change the string "App domain" by "Origin" in the app description. I like that idea, it's better than mine.
Flags: needinfo?(madrid.crespo)
Status: UNCONFIRMED → NEW
Component: General → Reviewer Tools
Ever confirmed: true
Summary: Origin needs "type:privilege", but it's not shown when reviewing → change 'app domain' in details to 'Origin'; and (for privileged apps) show it above the fold
(Assignee)

Updated

4 years ago
Assignee: nobody → mpillard
Priority: -- → P3
Whiteboard: [repoman]
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
Fixed in https://github.com/mozilla/zamboni/commit/672418aa545ecea8befc5096005b5d148176349b

STR:
- Submit a packaged app
- Go to the reviewers detail page for that app. The app origin should be shown, without needing to click to show more details

- Submit an hosted app
- Go to the reviewers detail page for that app. The app origin should be shown but this time you should need to click to show more details before seeing it.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-10-28

Comment 6

4 years ago
Verified as fixed in marketplace-dev.allizom.org
Packaged app:  http://screencast.com/t/9ofJFtCJ7a
Hosted app: http://screencast.com/t/QRRhmcUX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.