If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Blob URL returns xhr.status of 0

RESOLVED DUPLICATE of bug 716491

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 716491
3 years ago
3 years ago

People

(Reporter: nolan, Unassigned)

Tracking

32 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8503750 [details]
index.html - same test case as in the live example

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.101 Safari/537.36

Steps to reproduce:

Create a blob, create an object URL from that blob, fetch the blob with XHR.


Actual results:

xhr.status is 0


Expected results:

xhr.status should be 200

Here's a live example: http://bl.ocks.org/nolanlawson/0eac306e4dac2114c752

Notice that Firefox says the xhr.status is 0, whereas in Chrome it's correctly given as 200.

Comment 1

3 years ago
Thanks for the report!

With the live example I get "xhr.status is: 200" on a build from http://nightly.mozilla.org/

What build are you testing with? Do you get the same results with the nightly?
Flags: needinfo?(nolan)
I can confirm that Firefox32, Firefox33beta are reporting "0" but it's working in an nightly build that is responding with xhr.status 200
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

3 years ago
OK thanks, good to know!
Flags: needinfo?(nolan)
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 716491
You need to log in before you can comment on or make changes to this bug.