no off-line item in calendar property dialog in version Gdata 1.0.1

RESOLVED DUPLICATE of bug 1103637

Status

Calendar
Provider: GData
RESOLVED DUPLICATE of bug 1103637
4 years ago
4 years ago

People

(Reporter: I. Alvarez, Unassigned)

Tracking

Lightning 3.3

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

windows 7 pro x64
Thunderbird to 31.1.2, Lightning to 3.3.1, in French
I updated GDATA provider from 0.32 to 1.0.1

for test I removed Gdata provider 1.0.1 and reinstalled the older version (0.32)



Actual results:

Seen on 2 different computers.
I had to give my Google password.
My google calendars were automatically restarted (no events seen in the view then all OK after some processing; On one computer I had to delete and recreate the calendar since I had problems of duplicate events)
But google calendars are no longer available off-line.
The "off-line" item in the calendar properties dialog is not listed anymore with version 1.0.1.

When reinstalling previous version of the provider I lost the access to the google calendar. (Similar messages than described in bug https://bugzilla.mozilla.org/show_bug.cgi?id=1079659 : ... [Exception... "[xpconnect wrapped nsIURI]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file ...].

I had to suppress all the google calendars in Thunderbird, be patient (to avoid the rest of bug 1079659, it is essential to do nothing for a while), and recreate them as new calendars.
Seems to work again (with version 0.32)



Expected results:

with Gdata 0.32 :
- Google calendars are  available off-line (no longer with 1.0.1 version).
- Off-line item is available in the list of calendar properties when creating calendars or accessing to the properties of existing calendars (no longer seen in 1.0.1 version)
As far as I know the Provider for Google Calendar extension 1.0.1 automatically enables and enforces the offline cache for all its calendars. Is there a special reason why you want to turn off the offline cache?
(Reporter)

Comment 2

4 years ago
On the contrary : the cache doesn't work with version 1.0.1
If a computer is offline, events of Google calendars are not displayed (calendars appear to be empty).
I thought it was because the off-line item is not displayed in the dialog.
If it is supposed to be automatic then it is not working with version 1.0.1
(Reporter)

Comment 3

4 years ago
On the contrary : the cache doesn't work with version 1.0.1
If a computer is offline, events of Google calendars are not displayed (calendars appear to be empty).
I thought it was because the off-line item is not displayed in the dialog.
If it is supposed to be automatic then it is not working with version 1.0.1

(In reply to Stefan Sitter from comment #1)
> As far as I know the Provider for Google Calendar extension 1.0.1
> automatically enables and enforces the offline cache for all its calendars.
> Is there a special reason why you want to turn off the offline cache?
Displaying items when offline seems to work for me in 1.0.2. Please retest and reopen if its still an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 5

4 years ago
Hi guys,
Philipp, have you tried to start Thinderbird without internet connection, or you went offline with Thunderbird already running? Because in the latter case, my calendars keep working without any problem, but if I start Thunderbird when my notebook is already offline, then I can see only the empty calendars, just like Alvarez. I tried this on two Win 7 64 bit notebooks, with the exact same results. Without an internet connection, the Google calendars just don't load. I am using Thunderbird 31.3.0, Lightning 3.3.1 and Google Provider 1.0.2. I hope this can be fixed soon.
Best regards,
Csaba

Comment 6

4 years ago
Sorry guys, I've been trying to change the status for a while, but I have no idea how to do that?..
Status: RESOLVED → CONFIRMED
Resolution: --- → DOESN'TWORKFORME :)
See bug 1103637 for details, a demo version will be available in the evening.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1103637
You need to log in before you can comment on or make changes to this bug.