Closed Bug 1081976 Opened 7 years ago Closed 2 years ago

[prod] Watching or unwatching a page changed the main page title

Categories

(Websites :: wiki.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: AndreiH, Unassigned)

References

Details

(Whiteboard: [fromAutomation])

#STR:

1. Go to https://wiki.mozilla.org
2. Log in and see the current page title (is "MozillaWiki")
3. Click on "Add this page to your watchlist"
4. Investigate page title. (changes to "Main Page - MozillaWiki")

#Expected results:
Page title should remain the same.

#Actual results:
Page title changes to Main Page - MozillaWiki
Whiteboard: [fromAutomation]
Here is a screencast http://screencast.com/t/wbYzSAw4nSw
What's most strange about the behavior in the screencast is not that the title changes but that the main page content is replaced with messages about the watchlist actions. These are supposed to appear as tooltip overlaps near the watchlist button (star). 

Can you say more about the conditions under which you're testing? That looks like Windows. Which version of Firefox is it? Is javascript enabled?
I've tested this on Mac (10.10) using:
"geckoAppInfo": {
    "_v": 1,
    "vendor": "Mozilla",
    "name": "Firefox",
    "id": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
    "version": "32.0.3",
    "appBuildID": "20140923175406",
    "platformVersion": "32.0.3",
    "platformBuildID": "20140923175406",
    "os": "Darwin",
    "xpcomabi": "x86_64-gcc3",
    "updateChannel": "release"
  },
running our Selenium suite.
Yes JS is enabled.
This is expected behavior, and I think I can tell you the cause.

The actual title of the page is Main Page, which is why you see it everywhere (watchlist, etc.).

But we have custom CSS that hides the page title on that page:

https://wiki.mozilla.org/MediaWiki:Common.css
>>>
/* Suppress title on front page */
body.page-Main_Page h1.firstHeading { display:none; }
<<<

Presumably, there is some JavaScript in the Vector skin that uses the value of that element to initialize the title element. Since that element is not available, the title element defaults to the name of the wiki alone.
Glenn, Stephen - do you have what you need to restore coverage (and hopefully across the 3 environments)?  Thanks!
Flags: needinfo?(stephen)
Flags: needinfo?(glennrphoward)
We've found though is that for different users, the page title can differ! For some users, it's "MozillaWiki' where for others it's "Main Page - MozillaWiki'.

This raises some interesting questions:
1) Why is this differing for different users?
2) Which is the correct behavior?
3) Are both behaviors correct?
Flags: needinfo?(gphemsley)
Flags: needinfo?(glennrphoward)
Flags: needinfo?(ckoehler)
On a hunch, I checked out the user rights for Webqatest and found it was not part of any explicit groups. I added it to 'confirmed' group and that change resulted in the expected watchlist behavior. 

I've added Webqatest to 'confirm' group on stage and dev as well.

Will file another bug for whatever permissions issue is causing this.
Flags: needinfo?(ckoehler)
See Also: → 1082810
This should allow automation to pass again.
@Stephend, can you confirm this?
(In reply to glennrphoward from comment #8)
> This should allow automation to pass again.
> @Stephend, can you confirm this?

Yep, it literally fixed all three suites; thanks, Christie!
Brilliant! Thanks again Christie.
Flags: needinfo?(gphemsley)
Flags: needinfo?(stephen)

Mass-removing myself from cc; search for 12b9dfe4-ece3-40dc-8d23-60e179f64ac1 or any reasonable part thereof, to mass-delete these notifications (and sorry!)

Looks like this was resolved six years ago.

Changing to 'Fixed'

Spike

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.