Closed Bug 1082021 Opened 7 years ago Closed 7 years ago

Save reading list item data in the reading list service, allowing for syncing of content

Categories

(Cloud Services :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1123101

People

(Reporter: krudnitski, Unassigned)

Details

The intention is that once the contents of the Reading List are synced to mobile Firefox instances attached to Fx Account, the contents can be accessed offline (without the need for a live internet connection). It would be beneficial for this conversion to offline happens in the cloud instead of client-side.
I had to squint at this bug to figure out exactly what it was, and how it differed from Bug 1082011. Is this new summary what you meant, Karen?

In more long-winded form: don't just save URLs and metadata, but also save article *data* to avoid the need for clients to fetch from the web and extract article content.

We'd probably only save the reader mode version, not the full HTML content -- this is the approach Pocket takes.
OS: Windows 8.1 → All
Hardware: x86_64 → All
Summary: Convert contents of Reading List to allow for 'offline' access → Save reading list item data in the reading list service, allowing for syncing of content
Provided that's engineering speak to say that I can read an article saved in my Reading List without Internet access, then I'm fine with the new summary description!

Yes, I also suspect it will only be the reader mode version. The idea here is that we put the onus on server-side to do the conversion, specifically thinking about Project 105 as well.
OK.

Offline storage is mostly a client decision, just as we do now. So this bug is about server-side processing and storage.

Where the server part comes in is (a) whether any client needs to do the work, (b) whether all clients need to do the work, (c) whether you can get your saved article content even if the New York Times site is down, (d) whether you can get yesterday's saved article content even if Mozilla's datacenter is down.

Those answers will be (a) maybe/sometimes, (b) no, (c) yes, (d) yes.

(Current client-only reading list is (a) yes, (b) yes, (c) N/A, (d) yes.)
No longer blocks: 1082011
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123101
You need to log in before you can comment on or make changes to this bug.