Closed Bug 1082134 Opened 8 years ago Closed 8 years ago

[e10s] Failing to download entire file from SSL site in E10S mode

Categories

(Core :: Networking: File, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1073872
Tracking Status
e10s m4+ ---

People

(Reporter: cmtalbert, Unassigned)

Details

Attachments

(1 file)

3.37 MB, application/zip
Details
Attached file nspr logfile
This happens on both windows and linux. The file is not fully downloaded when the download is attempted in an E10S window, but it is fully downloaded when not in an E10S window. It might be a download manager issue, but filing here first, because it seems that the issue is server specific, and that sounds like more of a networking corner case issue with E10s and this specific server.

The only place I could get this to repro was the synergy-project download page. Other SSL http connections did not seem to have the issue(
tried nightly.mozilla.org, tried unsecured sites, etc). Since I'm not sure what is happening, I couldn't do smarter testing around the issue.

Here are the steps:
1. Open an E10S window
2. Go to: http://synergy-project.org/download/?file=synergy-1.5.1-r2398-Windows-x64.msi (you will have to log in, synergy is a nice system, you'll enjoy using it).  If someone is local to the bay area, come find me and we can debug on my account.
3. Download the .msi file in question
4. Open an non-E10S window
5. Go to http://synergy-project.org/download/?file=synergy-1.5.1-r2398-Windows-x64.msi
6. Download the .msi file in question

Review your download directory, you fill find the following:
e10s download: 7580461 Oct 13 12:42 /home/ctalbert/Downloads/synergy-1.5.1-r2398-Windows-x64(3).msi
non-e10s download: 8531968 Oct 13 12:42 /home/ctalbert/Downloads/synergy-1.5.1-r2398-Windows-x64(2).msi

The file size that is downloaded is consistent no matter how many times you download it, whether you download it on windows or linux. I will attach an nspr log from my linux attempt to download it. Search for the file name to find the interesting bits. Repro'd with a clean profile as well (just with the layers pref set to turn on E10s). And used today's nightly (2014-10-13) built from: https://hg.mozilla.org/mozilla-central/rev/f547cf19d104

You can download other files from the synergy site and experience the same issue, but there is some element of file size playing in here as well, because I was downloading smaller files and the issue was more intermittent. With this windows msi file, it happens every time like clockwork.
This sounds similar to the gmail attachment download bug that Gavin reported.
tracking-e10s: --- → ?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1073872
Clint, can you reproduce this from here?

https://synergy-project.org/nightly/

synergy stated charging on that download page you posted.
Flags: needinfo?(ctalbert)
(In reply to Jim Mathies [:jimm] from comment #3)
> Clint, can you reproduce this from here?
> 
> https://synergy-project.org/nightly/
> 
> synergy stated charging on that download page you posted.

Hey Jim,

No, I can't repro it with the nightly page, but I can still repro it with the original page where I reported it.  Is there anything I can do to help debug this?  I'm not super clear on what code to look at to get a handle on how we store files that are downloaded.
Flags: needinfo?(ctalbert)
You need to log in before you can comment on or make changes to this bug.