Closed Bug 1082154 Opened 5 years ago Closed 5 years ago

Use of uninitialized variable |rv| in |nsMaiInterfaceDocument::getDocumentAttributeValueCB|

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: erahm, Assigned: surkov)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: [CID 1244625][good first bug])

|getDocumentAttributeValueCB| only sets |rv| in one if branch [1], but then asserts its result [2] even though it may be uninitialized.

This appears to be a regression from bug 1068734.

[1] http://hg.mozilla.org/mozilla-central/annotate/71edd80236b2/accessible/atk/nsMaiInterfaceDocument.cpp#l108
[2] http://hg.mozilla.org/mozilla-central/annotate/71edd80236b2/accessible/atk/nsMaiInterfaceDocument.cpp#l116
Whiteboard: [CID 1244625] → [CID 1244625][good first bug]
hey, i am new to open source.
i want to work on this bug. can anybody guide me?
(In reply to kunal jain from comment #1)
> hey, i am new to open source.
> i want to work on this bug. can anybody guide me?

Hi Kunal,

Thanks for the interest, but it looks like this was fixed as part of Bug 1076816:
https://hg.mozilla.org/mozilla-central/diff/ef5d07a500fd/accessible/atk/nsMaiInterfaceDocument.cpp#l1.31
Assignee: nobody → surkov.alexander
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1076816
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.