Closed Bug 1082261 Opened 8 years ago Closed 8 years ago

http 421 retry

Categories

(Core :: Networking: HTTP, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: mcmanus, Assigned: mcmanus)

References

Details

(Whiteboard: [spdy])

Attachments

(1 file)

h2 says a client MAY retry based on 421 and should clear alt-svc mappings.

we already do the latter.. based on a prblem report on spdy-dev it seems its reasonable to do the retry (on a new connection) in the face of 421.. it shouldn't have any downside in the common path
Attached patch http 421 retrySplinter Review
Attachment #8504417 - Flags: review?(hurley)
Assignee: nobody → mcmanus
Status: NEW → ASSIGNED
Attachment #8504417 - Flags: review?(hurley) → review+
oh sorry, seems it was caused by the push before. Re-checkedin this changes in https://treeherder.mozilla.org/ui/#/jobs?repo=mozilla-inbound&revision=c9d867500a39
https://hg.mozilla.org/mozilla-central/rev/a2609830541a
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Depends on: 1179560
You need to log in before you can comment on or make changes to this bug.