Mozharness creates working directories in hg_share

RESOLVED DUPLICATE of bug 780800

Status

Release Engineering
Mozharness
RESOLVED DUPLICATE of bug 780800
3 years ago
3 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
eg this fennec beta l10n repack:

20:30:09     INFO - Running main action method: pull
20:30:09     INFO - mkdir: /builds/slave/rel-m-beta-and_rpk_3-000000000/build
20:30:09     INFO - Changing directory to /builds/slave/rel-m-beta-and_rpk_3-000000000/build.
20:30:09     INFO - retry: Calling <bound method MobileSingleLocale._get_revision of <__main__.MobileSingleLocale object at 0x1ade710>> with args: (<mozharness.base.vcs.mercurial.MercurialVCS object at 0x19c9750>, 'mozilla-beta'), kwargs: {}, attempt #1
20:30:09     INFO - Setting /builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta to https://hg.mozilla.org/releases/mozilla-beta revision FENNEC_34_0b1_RELEASE using shared directory /builds/hg-shared.
20:30:09     INFO - Checking if share extension works.
20:30:09     INFO - Getting output from command: ['hg', '--config', 'ui.merge=internal:merge', 'help', 'share']
20:30:09     INFO - Copy/paste: hg --config ui.merge=internal:merge help share
20:30:09     INFO - Reading from file tmpfile_stdout
20:30:09     INFO - hg share works.
20:30:09     INFO - Updating shared repo
20:30:09     INFO - Pulling https://hg.mozilla.org/releases/mozilla-beta to /builds/hg-shared/releases/mozilla-beta and updating.
20:30:09     INFO - Running command: ['hg', '--config', 'ui.merge=internal:merge', 'pull', 'https://hg.mozilla.org/releases/mozilla-beta'] in /builds/hg-shared/releases/mozilla-beta
20:30:09     INFO - Copy/paste: hg --config ui.merge=internal:merge pull https://hg.mozilla.org/releases/mozilla-beta
20:30:09     INFO -  warning: hg.mozilla.org certificate with fingerprint af:27:b9:34:47:4e:e5:98:01:f6:83:2b:51:c9:aa:d8:df:fb:1a:27 not verified (check hostfingerprints or web.cacerts config setting)
20:30:10     INFO -  pulling from https://hg.mozilla.org/releases/mozilla-beta
20:30:10     INFO -  searching for changes
20:30:10     INFO -  no changes found
20:30:10     INFO - Return code: 0

So far so good, but now we do an update to the release tag in the hg-share:

20:30:10     INFO - Updating /builds/hg-shared/releases/mozilla-beta revision FENNEC_34_0b1_RELEASE.
20:30:10     INFO - Running command: ['hg', '--config', 'ui.merge=internal:merge', 'update', '-C', '-r', 'FENNEC_34_0b1_RELEASE'] in /builds/hg-shared/releases/mozilla-beta
20:30:10     INFO - Copy/paste: hg --config ui.merge=internal:merge update -C -r FENNEC_34_0b1_RELEASE
20:33:49     INFO -  99356 files updated, 0 files merged, 0 files removed, 0 files unresolved
20:33:49     INFO - Return code: 0
20:33:49     INFO - Getting output from command: ['hg', '--config', 'ui.merge=internal:merge', 'parent', '--template', '{node|short}'] in /builds/hg-shared/releases/mozilla-beta
20:33:49     INFO - Copy/paste: hg --config ui.merge=internal:merge parent --template {node|short}
20:33:49     INFO - Reading from file tmpfile_stdout
20:33:49     INFO - Output received:
20:33:49     INFO -  b3068b39151a

Then we share to the actual build dir

20:33:49     INFO - Trying to share /builds/hg-shared/releases/mozilla-beta to /builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta
20:33:49     INFO - Sharing /builds/hg-shared/releases/mozilla-beta to /builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta.
20:33:49     INFO - Running command: ['hg', '--config', 'ui.merge=internal:merge', 'share', '-U', '/builds/hg-shared/releases/mozilla-beta', '/builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta']
20:33:49     INFO - Copy/paste: hg --config ui.merge=internal:merge share -U /builds/hg-shared/releases/mozilla-beta /builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta
20:33:50     INFO - Return code: 0

And update again (!!!)

20:33:50     INFO - Updating /builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta revision FENNEC_34_0b1_RELEASE.
20:33:50     INFO - Running command: ['hg', '--config', 'ui.merge=internal:merge', 'update', '-C', '-r', 'FENNEC_34_0b1_RELEASE'] in /builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta
20:33:50     INFO - Copy/paste: hg --config ui.merge=internal:merge update -C -r FENNEC_34_0b1_RELEASE
20:34:36     INFO -  99370 files updated, 0 files merged, 0 files removed, 0 files unresolved
20:34:36     INFO - Return code: 0
20:34:36     INFO - Getting output from command: ['hg', '--config', 'ui.merge=internal:merge', 'parent', '--template', '{node|short}'] in /builds/slave/rel-m-beta-and_rpk_3-000000000/build/mozilla-beta
20:34:36     INFO - Copy/paste: hg --config ui.merge=internal:merge parent --template {node|short}
20:34:36     INFO - Reading from file tmpfile_stdout
20:34:36     INFO - Output received:
20:34:36     INFO -  b3068b39151a

Is this intended ? Pretty sure it's different from what happens on desktop with hgtool.

Comment 1

3 years ago
bug 780800 ? in theory it shouldn't be difficult to add a -U.
(Reporter)

Comment 2

3 years ago
Yay my memory!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780800
We should just have mozharness use hgtool instead of always having an out-of-date reimplementation of it.
You need to log in before you can comment on or make changes to this bug.