Paid apps can be saved only for Android platforms in Compatibility & Payments page

VERIFIED FIXED in 2014-10-14

Status

Marketplace
Developer Pages
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Iulian Timis, Assigned: scolville)

Tracking

2014-10-14
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [see comment 2])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Load My Submission landing page https://marketplace.allizom.org/developers/submissions
2. Click the Compatibility & Payments link for a submitted paid packaged app.
3. Deselect the Firefox OS platform and select Firefox Mobile and Firefox Tablet.
4. Save Changes.

Expected results:
Firefox OS platform is mandatory for paid packaged apps and an error is displayed. 

Actual results:
There are no errors displayed, the changes are successfully saved. The user is unable to submit a packaged paid app only for Android, without also selecting the Firefox OS platform, therefore it should not be able to save a paid packaged app only for Android platform.

Notes/Issues:
Verified on FF36 (Win 7).
Screencast for this issue http://screencast.com/t/99p5YZu9V4G

Updated

4 years ago
Blocks: 909896
Priority: -- → P3

Comment 1

4 years ago
The bug here is that I cannot submit a paid packaged app which is android-specific.

STR:
1. Load https://marketplace.allizom.org/developers/submit/?src=nav
2. Switch to the Paid/in-app tab
3. Select Android as a platform

expected behavior:
Packaged app is an option if android is the only platform selected

actual behavior:
Packaged app option disappears if android is selected.

screenshot: https://www.dropbox.com/s/iq9e2lwknvpxlqz/Screenshot%202014-10-14%2013.24.44.png?dl=0
Priority: P3 → --
Whiteboard: [see comment 2]

Updated

4 years ago
Priority: -- → P3

Comment 3

4 years ago
Stuart, this looks like the only remaining blocker for Android, I know that form gets hairy though, would you mind taking a quick look?
Assignee: nobody → scolville
https://github.com/mozilla/zamboni/commit/5ae69626de85f7faafc441304664ecbd341e4867
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

4 years ago
Created attachment 8523894 [details]
android-specific_packaged.png

Verified as fixed in https://marketplace.allizom.org/developers/submit/ on FF36 (Win 7).
Attaching postfix screenshot.
Closing bug.
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.