[Flame][Video] When camera is started by the video app, the mode switch displays incorrectly

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: njpark, Assigned: wilsonpage)

Tracking

({regression})

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
STR:
Open Video app, then press Camera icon to activate camera

Actual:
The camera app starts, and switches to video mode, but the mode switch shows video icon on both sides.

Version info:
Gaia-Rev        baaff455fd2c42c6319df77e1b77ee49c9e45ca5
Gecko-Rev       
Build-ID        20141014100256
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141010.070448
FW-Date         Fri Oct 10 07:04:59 EDT 2014
Bootloader      L1TC00011840
Reporter

Updated

5 years ago
Reporter

Comment 1

5 years ago
This does not reproduce in 2.1 build
Reporter

Comment 2

5 years ago
Blocking reason:  broken UI that can confuse the user
blocking-b2g: --- → 2.2?
It seems this happens only when the camera app is not already running. When the camera app is running, this issue does not reproduce. No-jun, can you confirm?
Flags: needinfo?(npark)
Reporter

Comment 4

5 years ago
(In reply to Russ Nicoletti [:russn] from comment #3)
> It seems this happens only when the camera app is not already running. When
> the camera app is running, this issue does not reproduce. No-jun, can you
> confirm?

That's correct, the switch is already moved to the right side where the camcorder icon is when camera app was running on the background already, and video app triggers to activate the camera app.
Flags: needinfo?(npark)
Reporter

Comment 5

5 years ago
(In reply to Russ Nicoletti [:russn] from comment #3)
> It seems this happens only when the camera app is not already running. When
> the camera app is running, this issue does not reproduce. No-jun, can you
> confirm?

Actually, let me correct myself.  What I mentioned in Comment 4 happens only if camera was selected for camcorder previously.  If the camera app has the photo mode selected, the bug still occurs in master.
Reporter

Updated

5 years ago
Keywords: regression

Comment 6

5 years ago
Blocking Reason: regression, broken button icons
blocking-b2g: 2.2? → 2.2+
Component: Gaia::Video → Gaia::Camera
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140919122247
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 85ca2e799c13
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140919123746
Gaia: 3fdde421696be8b81c60b236c9fa7c9d8a6370fe
Gecko: 443c677ebe58
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 3fdde421696be8b81c60b236c9fa7c9d8a6370fe
Gecko: 85ca2e799c13

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 443c677ebe58

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c...3fdde421696be8b81c60b236c9fa7c9d8a6370fe

Caused by Bug 1066660.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Possibly broken by bug 1066660 - can you take a look Wilson?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(wilsonpage)
Assignee

Comment 9

5 years ago
REASON

We were attempting to set the switch position before the switch was in the DOM.

FIX

Wait till controls view is 'inserted' before setting up the the switch.
Flags: needinfo?(wilsonpage)
Attachment #8507825 - Flags: review?(jdarcangelo)
Assignee

Updated

5 years ago
Assignee: nobody → wilsonpage
Comment on attachment 8507825 [details] [review]
pull-request (master)

A couple small nits in the PR, but the main issue is that I don't see any new tests added. We should probably add some tests here before landing.
Attachment #8507825 - Flags: review?(jdarcangelo) → review-
(In reply to Justin D'Arcangelo [:justindarc] from comment #10)
> Comment on attachment 8507825 [details] [review]
> pull-request (master)
> 
> A couple small nits in the PR, but the main issue is that I don't see any
> new tests added. We should probably add some tests here before landing.

Also, should we specify a version number in bower.json for "gaia-components/drag"?
Assignee

Comment 12

5 years ago
Comment on attachment 8507825 [details] [review]
pull-request (master)

- Added test
- Fixed nits
Attachment #8507825 - Flags: review- → review?(jdarcangelo)
Comment on attachment 8507825 [details] [review]
pull-request (master)

Two additional comments in the PR. The only comment I'd like to see addressed before you land is that you're not using the `pointer` abstraction when removing event listeners. The other comment is more of an observation and doesn't need addressed here.
Attachment #8507825 - Flags: review?(jdarcangelo) → review+
Assignee

Comment 14

5 years ago
(In reply to Justin D'Arcangelo [:justindarc] from comment #13)
> Comment on attachment 8507825 [details] [review]
> pull-request (master)
> 
> Two additional comments in the PR. The only comment I'd like to see
> addressed before you land is that you're not using the `pointer` abstraction
> when removing event listeners. The other comment is more of an observation
> and doesn't need addressed here.

I understand the second point, and tried a few approaches to keep that complexity in the library, but failed. I don't have too much time to spend on this unfortunately.
Assignee

Updated

5 years ago
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED

Comment 16

5 years ago
Verified the issue is fixed on 2.2 Flame

When open "Camera" from the "Video" app, the switcher shows correct icons

Device: Flame 2.2 Master
BuildID: 20141124040203
Gaia: c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1
Gecko: 8c02f3280d0c
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.