Closed Bug 1082630 Opened 10 years ago Closed 6 years ago

When on Mute, constant silent tick sounds are hearable

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: marek.raida, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

On Flame, latest 2.1 build.
I mute all sounds on Homescreen


Actual results:

but very silent, but still hearable and disturbing rapid ticks are there from the speaker and remain also after reboot (as soon as Firefox OS logo appears). What helps is only longer time in standby mode.
Returning sound level to some not-mute value does not help either (after being in mute level). It is perceivable also in not completely silent environment (in office, for example)


Expected results:

I expect no sound from the speaker, not even silent ticks, when there is no activity and esp. when there is MUTE mode on.
It is becoming more pressing. During call it is still there and it is very unpleasant.
I do not believe it to be HW issue and surely must be plaguing others as well.
It perhaps could be related to some previous game run (Back to Candyland in my case) .. thin ticks are there, cannot be easily avoided and are quite ruining telephony-calls...
The speaker noise I think the root cause is the same as Bug 1079810.
For the tick sound during the phone call, I just try  to set the airplane mode on and the tick sound would disappear. That means the audio physical circuit may be interfered by GSM module.
You're right, Flight mode solves this and it would be probably the same problem.
So I will close this issue as duplicated to referenced one, although I'm not pointing out power consumption but something else...
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
I'm reopening this issue because tick sounds are still there and https://bugzilla.mozilla.org/show_bug.cgi?id=1079810 did not solved it.
It definitely is some interfering problem, and most probably WIFI related, but it is worse at office and not so problematic at home, so it depends on WIFI router or number of networks available.
Turning WIFI off solves the problem but it is back as soon as it connects to the network and some data starts flowing through.
Are you anybody able to reproduce?
IMHO it is serious problem, forcing me to have WIFI turned off.

Hmm, but as I tested right now, it is surely data related rather than WIFI solely, because 3G/EDGE data module is causing the same problem.

Try to:
1. be in very silent environment and turn data ON
2. Open browser and visit some URL
3. You should hear some silent rapid ticking, not depending in current sound volume (and sometimes they are louder then other times)
4. is is very uncomfortable during audio calls but even having the phone (Flame device with latest 2.2 OS) one the desk next to me is disturbing

I was not able to reproduce it on FFOS 2.0 and lower...
problem remains, reopening with more info...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.