middle clicking on a link in a site using <link> to a site that doesn't use <link> doesn't update toolbar

RESOLVED DUPLICATE of bug 102905

Status

defect
RESOLVED DUPLICATE of bug 102905
18 years ago
11 years ago

People

(Reporter: pretzalz, Assigned: hyatt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

()

Easiest way to explain is steps to reproduce...
1) Go to Slashdot(http://slashdot.org)
2) Middle-click on a link to an outside story with Site Navigation Bar set to
"Show Only as needed.

Expected results: the link opens in a new tab, if this site doesn't use <link>
than the Site Navigation Bar should disappear. 

Actual results: If the new site doesn't have <link> than it keeps the <link>s of
the site(ie Slashdot) that you came from. I have been unable to test what
happens if the new site uses <link>, but opening a bug report which should have
<link> from a place which doesn't use <link> with middle click doesn't open the
Site Navigation Bar although if you switch from Show As Needed to Show Always
than toolbar appears correct.  More generally, when you switch between tabs, the
Site Navigation toolbar isn't updated(ie switch from this bug report to a tab
that shouldn't have <link>...)

*** This bug has been marked as a duplicate of 102905 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.