Buttons don't appear in the customization palette if they've already been put elsewhere.

RESOLVED INVALID

Status

defect
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: abr, Unassigned)

Tracking

unspecified
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:

1. Start an older released version of Firefox (e.g. 33)
2. Customize the toolbar buttons
3. Start Beta 34 using the same profile
4. Go to about:config and change "loop:throttled" to "false"
5. Restart Beta 34
6. Open the customization palette.

The Hello button should be in the customization palette at this point; however, it does not show up (presumably due to the fact that it had been customized earlier). The button can be forced to show up by clicking "Restore Defaults," but that can be very disruptive.
I'm nominating this to block Loop-34 since this will greatly inhibit the exposure this gets in Beta.
backlog: --- → Fx34?
Mike --What would be needed to fix this?
Flags: needinfo?(mdeboer)
It would need bug 1081888 to be resolved.
Depends on: 1081888
Flags: needinfo?(mdeboer)
(In reply to Mike de Boer [:mikedeboer] from comment #3)
> It would need bug 1081888 to be resolved.

Mike, I'd like to know more about how you came to this conclusion so I can understand what's going on better.
Flags: needinfo?(mdeboer)
We believe this resulted from doing unsupported operations in a specific, one-off profile.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Flags: needinfo?(mdeboer)

Comment 6

5 years ago
This bug should not be marked as invalid. I had the same issue, it's not a 'specific, one-off profile' thing either.
I tested on Linux, Mac OSX and Windows. all the profile had at least 2 new buttons added in the user customization window. Even after a full reset, the Firefox Hello chat bubble did not appear.
It was only after doing the 'about:config and change "loop:throttled" to "false" ' change that the chat bubble appeared.

Please change this bug to UNRESOLVED VALID.
This bug is about what happens when Loop is unthrottled or if your build gets though the throttling. It's intentional that you won't see it at all until that point.

Comment 8

4 years ago
This is not resolved and this is not invalid.

I had no hello button in firefox even after removing existing profile and launching fresh.

However, once I went into about:config and set loop:throttled to false it appeared right away.

Resetting layout to default did not make it appear.

I'm on Windows 8.1.
(Reporter)

Comment 9

4 years ago
(In reply to Alex Oreshkin from comment #8)
> This is not resolved and this is not invalid.

See comment #7.

Right now (December 1st), the throttle is set to 10%. Your browser has only a one-in-ten chance of having the Hello button show up. We will increase this number as we become confident that the servers can take the load. All you've done is hack around the throttling mechanism that is designed to protect our servers.

Renaming to reflect the actual behavior that prompted filing this bug in the first place.
Group: mozilla-employee-confidential
Summary: Hello button does not appear in palette if customized prior to FFx34 → Buttons don't appear in the customization palette if they've already been put elsewhere.
(Reporter)

Updated

4 years ago
Group: mozilla-employee-confidential
You need to log in before you can comment on or make changes to this bug.