improve layer-tree dumping

RESOLVED FIXED in mozilla36

Status

()

Core
Layout
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
mozilla36
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments)

2.42 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
6.30 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
3.85 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
8.32 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
1.29 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
1.84 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
5.15 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
1.56 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
3.66 KB, patch
mattwoodrow
: review+
Details | Diff | Splinter Review
Comment hidden (empty)
Created attachment 8505947 [details] [diff] [review]
Part 1: Remove nsDisplayZoom::Paint since it's dead code
Attachment #8505947 - Flags: review?(matt.woodrow)
Created attachment 8505948 [details] [diff] [review]
Part 2: Inline nsDisplayList::PaintForFrame into PaintRoot
Attachment #8505948 - Flags: review?(matt.woodrow)
Created attachment 8505949 [details] [diff] [review]
Part 3: Flush displaylist dump before calling PaintRoot
Attachment #8505949 - Flags: review?(matt.woodrow)
Created attachment 8505950 [details] [diff] [review]
Part 4: Return LayerManager from nsDisplayList::PaintRoot, and dump its contents in nsLayoutUtils::PaintFrame
Attachment #8505950 - Flags: review?(matt.woodrow)
Created attachment 8505951 [details] [diff] [review]
Part 5: ClientLayerManager::BeginTransactionWithTarget should assert if we're not going to take a snapshot
Attachment #8505951 - Flags: review?(matt.woodrow)
Created attachment 8505952 [details] [diff] [review]
Part 6: Rename viewport to scrollport in ScrollFrameHelper::ComputeFrameMetrics
Attachment #8505952 - Flags: review?(matt.woodrow)
Attachment #8505947 - Flags: review?(matt.woodrow) → review+
Attachment #8505948 - Flags: review?(matt.woodrow) → review+
Attachment #8505949 - Flags: review?(matt.woodrow) → review+
Attachment #8505950 - Flags: review?(matt.woodrow) → review+
Attachment #8505951 - Flags: review?(matt.woodrow) → review+
Attachment #8505952 - Flags: review?(matt.woodrow) → review+
Created attachment 8516548 [details] [diff] [review]
Create nsDOMWindowUtils::UpdateLayerTree and use it to flush layers in reftest content processes instead of doing a DRAW_WIDGET_LAYERS drawWindow. r=mattwoodrow
Attachment #8516548 - Flags: review?(matt.woodrow)
Created attachment 8516549 [details] [diff] [review]
Part 4.5: Avoid requesting PAINT_WIDGET_LAYERS if we're in a content process
Attachment #8516549 - Flags: review?(matt.woodrow)
Attachment #8516548 - Flags: review?(matt.woodrow) → review+
Attachment #8516549 - Flags: review?(matt.woodrow) → review+
Unfortunately this seems to break e10s plugin reftests. You can reproduce as follows:
  mach reftest --e10s dom/plugins/test/reftest/reftest.list

We're currently running e10s reftests on all checkins but they're hidden because of this problem. Rob, if it takes longer than a few hours to fix this, would it be okay if we back this change out?
Flags: needinfo?(roc)
Also, if it helps, this is the bad cset:

The first bad revision is:
changeset:   213937:80142bab0f14
user:        Robert O'Callahan <robert@ocallahan.org>
date:        Tue Nov 04 17:05:44 2014 +1300
summary:     Bug 1083635. Part 4.2: Create nsDOMWindowUtils::UpdateLayerTree and use it to flush layers in reftest content processes instead of doing a DRAW_WIDGET_LAYERS drawWindow. r=mattwoodrow
(In reply to Bill McCloskey (:billm) from comment #12)
> Unfortunately this seems to break e10s plugin reftests. You can reproduce as
> follows:
>   mach reftest --e10s dom/plugins/test/reftest/reftest.list
> 
> We're currently running e10s reftests on all checkins but they're hidden
> because of this problem.

If they're hidden because of this problem, why didn't they show up in https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=c45a80b4dd60 ?

> Rob, if it takes longer than a few hours to fix
> this, would it be okay if we back this change out?

OK I guess but let me try to fix it.
Flags: needinfo?(roc)
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #14)
> (In reply to Bill McCloskey (:billm) from comment #12)
> If they're hidden because of this problem, why didn't they show up in
> https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=c45a80b4dd60 ?

These tests are new. It takes about a day to get tests running on tbpl once we know they're green. We just got unlucky in that this bug regressed the tests during that short time. There was nothing you could have done to avoid this.
Created attachment 8518543 [details] [diff] [review]
Part 7: Fix UpdateLayerTree to sync-decode im pending notifications

This fixes the e10s plugins issue.
Attachment #8518543 - Flags: review?(matt.woodrow)
Attachment #8518543 - Flags: review?(matt.woodrow) → review+
You need to log in before you can comment on or make changes to this bug.