If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Notifications text in utility tray slightly truncated in some locales

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: gmarty, Assigned: gmarty)

Tracking

unspecified
2.1 S7 (24Oct)
x86_64
Linux

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Created attachment 8506037 [details]
2014-10-16-10-48-12.png

Because the Notifications title in the utility tray is in italic, it is slightly cut on the right hand side.
This appears mostly on locale non using latin script (Japanese, Chinese, languages spoken in India...)

Comment 1

3 years ago
Which build, master?

I am on v2.1 and this same text is not truncated because it is not italicized.
(Assignee)

Comment 2

3 years ago
Created attachment 8506840 [details] [review]
Github PR

The fix is one liner. Etienne, can you give me a r+ on that?
Attachment #8506840 - Flags: review?(etienne)
(Assignee)

Updated

3 years ago
Assignee: nobody → gmarty
Comment on attachment 8506840 [details] [review]
Github PR

Sorry but I don't understand the bug.
#notification-some is not fixed-width, why are we overflowing?

If we need to work around a platform issue we should file it first and reference it in a comment.
Attachment #8506840 - Flags: review?(etienne)
Whiteboard: [systemsfe]
(Assignee)

Comment 4

3 years ago
Comment on attachment 8506840 [details] [review]
Github PR

I agree with you about the riskiness of removing the overflow hidden here.
Fixing this issue with a non breaking space for 2.1 (v2.2 uses flexbox since Bug 1062314 landed but it was decided not to uplift it).

Also added some context in a comment.
Attachment #8506840 - Flags: review?(etienne)
(Assignee)

Comment 5

3 years ago
Related to Bug 1086211
Comment on attachment 8506840 [details] [review]
Github PR

perfect, thanks!
(let's make sure we get a green try, we might have test inspecting this part of the DOM)
Attachment #8506840 - Flags: review?(etienne) → review+
(Assignee)

Comment 7

3 years ago
Comment on attachment 8506840 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Utility tray visual refresh
[User impact] if declined: Some characters can be cropped on the utility tray on some languages (including markets where we launched).
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Very low as it is just a one-liner
[String changes made]: None
Attachment #8506840 - Flags: approval-gaia-v2.1?(bbajaj)
(In reply to Guillaume Marty [:gmarty] from comment #7)
> Comment on attachment 8506840 [details] [review]
> Github PR
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): Utility tray visual refresh
> [User impact] if declined: Some characters can be cropped on the utility
> tray on some languages (including markets where we launched).
> [Testing completed]: Manual testing
> [Risk to taking this patch] (and alternatives if risky): Very low as it is
> just a one-liner
> [String changes made]: None

Is this a 2.1 regression? The patch looks simple/low risk and should be fine to get landed once resolved on trunk, but I want to confirm if we landed something in 2.1 that regressed this or are you seeing the same behavior in 2.0 as well ?
Flags: needinfo?(gmarty)
(Assignee)

Comment 9

3 years ago
It's not a regression as the utility tray visual refresh first landed in v2.1 (v2.0 still has the same old look since v1.3).
Flags: needinfo?(gmarty)
Does that work well with LTR locales?
Flags: needinfo?(gmarty)
(In reply to Fabrice Desré [:fabrice] from comment #10)
> Does that work well with LTR locales?

And... I meant RTL of course!
(Assignee)

Comment 12

3 years ago
Comment on attachment 8506840 [details] [review]
Github PR

Good call Fabrice, this bug appears on Arabic too. The patch now uses padding-right instead of the non breaking space that is direction sensitive.
I checked under several locales configuration and it doesn't appear to have any bad side effects. Etienne, can you please review it?
Flags: needinfo?(gmarty)
Attachment #8506840 - Flags: review+ → review?(etienne)
Comment on attachment 8506840 [details] [review]
Github PR

lgtm
Attachment #8506840 - Flags: review?(etienne) → review+
Target Milestone: --- → 2.1 S7 (24Oct)
(Assignee)

Comment 14

3 years ago
Landed in v2.1 branch in https://github.com/mozilla-b2g/gaia/commit/5a3e34fb6d1299a4cb272db843c40f40c2febc5f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(In reply to Guillaume Marty [:gmarty] from comment #14)
> Landed in v2.1 branch in
> https://github.com/mozilla-b2g/gaia/commit/
> 5a3e34fb6d1299a4cb272db843c40f40c2febc5f

So... you landed on 2.1 before getting approval?
(Assignee)

Comment 16

3 years ago
I had completely forgot I needed approval before landing v2.1 specific bugs. Shall I request approval now?
Bug 1082935 is in the same case. I'm sorry about that.
Flags: needinfo?(fabrice)
(In reply to Guillaume Marty [:gmarty] from comment #16)
> I had completely forgot I needed approval before landing v2.1 specific bugs.
> Shall I request approval now?
> Bug 1082935 is in the same case. I'm sorry about that.

Yes, you need backout Bug 1082935 from 2.1 and reland once you have approval. Only master doesn't need approval.
Flags: needinfo?(fabrice)
Attachment #8506840 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
status-b2g-v2.1: --- → fixed
Issue verified fixed on Flame 2.1 & Flame 2.2

Actual Results: All available non-latin locales show Notifications header text that is not cut off. Same was tested on 2.2 to the extent translations exist for build.


Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031001201
Gaia: f89c7b12c36572262c9ea76058694a139b1a8634
Gecko: 50d48f8a04c7
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.