All fields in the Mailing list editor dialog are empty. Regression caused by Bug 1061648

RESOLVED FIXED in seamonkey2.33

Status

defect
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: philip.chee, Assigned: philip.chee)

Tracking

(Blocks 1 bug, {regression})

Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.33+ fixed)

Details

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #1061648 +++

1. Double-click a non-empty mailing list. Mailing List dialog appears.
2. Try to edit the list.

Actual results:
All fields are blank

Expected results:
Dialog opens with all the fields pre filled ready for add/delete operations.

Regression caused by Bug 1061648
r?mconley for the /mail/ and /mailnews/ changes
r?IanN for the /suite/ changes

> -    inParam: {
> -      abCard: abCard,
> -      listUri: listUri,
> -    },
> -    outParam: {
inParam, outParam <- over engineered.

> -      ok: false, // true if OK in dialog is clicked
> -    },
> +    abCard: abCard,
> +    listURI: listUri,
s/listUri/listURI/ for extension backward compatibility.

> +    refresh: false, // true if OK in dialog is clicked
s/ok/refresh/ make this parameter reflect what it does i.e. refresh.

> -  gListCard = window.arguments[0].inParam.abCard;
> -  var listUri  = window.arguments[0].inParam.listUri;
> -  window.arguments[0].outParam.ok = false;
This is already false, setting this to false again is useless churn.

> +  gListCard = window.arguments[0].abCard;
> +  var listUri  = window.arguments[0].listURI;
reverted for extension backward compatibility.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8506226 - Flags: review?(mconley)
Attachment #8506226 - Flags: review?(iann_bugzilla)
Attachment #8506226 - Flags: review?(iann_bugzilla) → review+
Still needs review for /mail/ and /mailnews/ parts.
Flags: needinfo?(mconley)
Comment on attachment 8506226 [details] [diff] [review]
Patvch v1.0 Proposed fix.

Review of attachment 8506226 [details] [diff] [review]:
-----------------------------------------------------------------

I'm fine with this - just a documentation nit.

::: mail/components/addrbook/content/abCommon.js
@@ +483,5 @@
>  {
>    let params = {
> +    abCard: abCard,
> +    listURI: listUri,
> +    refresh: false, // true if OK in dialog is clicked

I'm fine collapsing the in/out params into the same object, but I'd really like to make it clear that refresh is an out param - perhaps in this comment here.
Attachment #8506226 - Flags: review?(mconley) → review+
Flags: needinfo?(mconley)
Pushed to comm-central
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.33
Blocks: 1106783
(In reply to Philip Chee from comment #4)
> Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/c5514726f0fc
Pushed bustage fix:
http://hg.mozilla.org/comm-central/rev/133b9c847d7e
[Approval Request Comment]
Regression caused by: Bug 1083785
User impact if declined: minor 
Testing completed (on m-c, etc.): baked on comm-central 1+ months.
Risk to taking this patch (and alternatives if risky): none typo fix.
String changes made by this patch: None.

I pushed a typo fix to comm-central
http://hg.mozilla.org/comm-central/rev/133b9c847d7e
Attachment #8543151 - Flags: approval-comm-aurora?
Comment on attachment 8543151 [details] [diff] [review]
Typo fix patch

I guess this never made it to comm-aurora.
Attachment #8543151 - Flags: approval-comm-aurora? → approval-comm-aurora-
You need to log in before you can comment on or make changes to this bug.