Public API: CheckDefineProperty excludes many legal property definition invocations.

RESOLVED DUPLICATE of bug 1124934

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1124934
4 years ago
4 years ago

People

(Reporter: efaust, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
ES6 has very specific rules for what defineProperty invocations are acceptable on non-configurable properties. CheckDefineProperty() outlaws everything except toggling [[Writable]]. This is incorrect.
And it's gone :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124934
You need to log in before you can comment on or make changes to this bug.