Closed Bug 1084371 Opened 5 years ago Closed 4 years ago

Update visual style of mixed content/tracking protection notifications in site identity popup

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected
firefox36 --- affected

People

(Reporter: cornel_ionce, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Environment: 
Device: Asus Transformer Tab (Android 4.2.1);
Build: Nightly 36.0a1 (2014-10-16);

Steps to reproduce:
1. Visit https://ie.microsoft.com/testdrive/browser/mixedcontent/assets/woodgrove.htm
2. Tap on the Mixed Content Shield icon from the URL bar.

Expected result:
Mixed content pop-up blocker pop-up is correctly displayed.

Actual result:
The top part of the pop-up has a lighter color than the pop-up (please see attached screenshot).
What about other door-hangers?
I believe this was by design. This doesn't affect other doorhangers, just the site identity popup.

This is not a regression, so we can look into this as part of bug 1058818.
Blocks: site-id-v2
This is indeed by design, but maybe that design is confusing. We can morph this bug to be about improving the design.

Low priority right now, but something for antlam to think about as part of the "better doorhangers" effort.
Flags: needinfo?(alam)
Summary: The top part of the Mixed Content has a lighter color than the rest of the pop-up → Update visual style of mixed content/tracking protection notifications in site identity popup
Will be posting designs soon in bug 1088220 that will probably affect this as well.
Flags: needinfo?(alam)
As commented on in bug 1088220, attaching latest WIP mock of the visual clean up.
I'm not sure how this is different from bug 1175972 - maybe this should be about mixed content only?
Blocks: tp-v1
Flags: needinfo?(alam)
Looks like this was originally about the difference in visuals. Either way, there are a couple bugs floating around right now so I'd like to clean this up. 

After some of the work that Liuche did, they're no longer different colors so I'm going to close this.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(alam)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.