Closed Bug 1084440 Opened 5 years ago Closed 5 years ago

OMTC causes lag in Firefox 33

Categories

(Core :: Graphics, defect)

33 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1089183

People

(Reporter: dustnmud, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

After updating to version 33 there's severe lag in UI responsiveness. More notably when selecting text (in page or a url in the address bar) in can take 3-4 seconds until the text appears selected. 

Also, clicking in dropdown menus is not accurate. 

At first I though it might have something to do with hardware acceleration, but disabling it didn't solve it. Then I read the issue with the black screen and OMTC. Disabling OMTC (layers.offmainthreadcomposition.enabled;false) fixes this problem.

My graphics drivers are outdated but it's a laptop and the manufacturer won't provide with newer ones.

ATI Mobility Radeon HD 5165
Adapter Drivers	atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	1024
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID	0x9480
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16492)
Driver Date	9-8-2009
Driver Version	8.653.0.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (ATI Mobility Radeon HD 5165 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
I guess it's the only workaround for you, disabling OMTC in about:config (as you did) due to your outdated card.

Maybe Mozilla should add this driver version to the blacklist.
Component: Untriaged → Graphics
Product: Firefox → Core
>Maybe Mozilla should add this driver version to the blacklist.

That's why I posted this. I was thinking of posting it as a comment on the other bug with the black screen.
(In reply to coinman from comment #0)

Could you try to disable D3D11 compositing and Direct2D rendering, while still using D3D9 for compositing?

To do this, go to about:config, set
 - layers.prefer-d3d9 to true
 - gfx.direct2d.disabled to true
and restart the browser.

If one of the prefs is missing from the about:config page, you can add it with right click > new > boolean.

This will tell us whether we need to blacklist the driver entirely or if we can still do accelerated compositing through D3D9.
OK, so I re-enabled OMTC and did as you said 
> - layers.prefer-d3d9 to true
> - gfx.direct2d.disabled to true
and it works fine now.
Scratch my previous comment. I noticed a glitch.

http://i.imgur.com/EpAkrTD.jpg
Is there a more up to date driver?
(In reply to Milan Sreckovic [:milan] (PTO 10/16-10/17) from comment #6)
> Is there a more up to date driver?

AMD has some updated drivers, but they can't be installed on Toshiba laptops last time I checked (iirc there's some workaround to do it manually, but it's not supported) and Toshiba hasn't updated theirs.
Blocks: 1088034
(In reply to coinman from comment #7)
> (In reply to Milan Sreckovic [:milan] (PTO 10/16-10/17) from comment #6)
> > Is there a more up to date driver?
> 
> AMD has some updated drivers, but they can't be installed on Toshiba laptops
> last time I checked (iirc there's some workaround to do it manually, but
> it's not supported) and Toshiba hasn't updated theirs.

A quick forum search yielded this info: http://goo.gl/BD21ni

Apparently those driver will work on *any* laptop with kludged drivers such as the Toshiba. Can you give them a try? They're 2011 but at least that's newer than 2009. The instructions are pretty detailed and the forum from which I obtained this info said to be exacting in following the instructions. I'd also suggest having the installer for the drivers you currently have.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089183
(In reply to Arthur K. from comment #8)
> (In reply to coinman from comment #7)
> > (In reply to Milan Sreckovic [:milan] (PTO 10/16-10/17) from comment #6)
> > > Is there a more up to date driver?
> > 
> > AMD has some updated drivers, but they can't be installed on Toshiba laptops
> > last time I checked (iirc there's some workaround to do it manually, but
> > it's not supported) and Toshiba hasn't updated theirs.
> 
> A quick forum search yielded this info: http://goo.gl/BD21ni
> 
> Apparently those driver will work on *any* laptop with kludged drivers such
> as the Toshiba. Can you give them a try? They're 2011 but at least that's
> newer than 2009. The instructions are pretty detailed and the forum from
> which I obtained this info said to be exacting in following the
> instructions. I'd also suggest having the installer for the drivers you
> currently have.

Apparently the link to the updated Catalyst drivers was broken. Users in that forum reported success with 13-1-legacy_vista_win7_win8_64_dd_ccc.exe on kludged Toshiba laptops. Updated link to those drivers here: http://goo.gl/gFkhPO
You need to log in before you can comment on or make changes to this bug.