Views are broken [Error: NS_NOINTERFACE accessing nsIScrollBoxObject in calendar-multiday-view.xml]

RESOLVED FIXED in 3.8

Status

Calendar
Calendar Views
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Stefan Sitter, Assigned: Stefan Sitter)

Tracking

({regression})

Trunk
regression

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Thunderbird/36.0a1 Lightning/3.8a1 BuildID/20141017030201

Calendar views are broken and flickering all the times.

The following error is reported many times in console:
> Error: NS_NOINTERFACE: 
> Source File: chrome://calendar/content/calendar-multiday-view.xml
> Line: 3714

Error is produced on the following query interface call:
> let scrollbox = document.getAnonymousElementByAttribute(this, "anonid", "scrollbox");
> let scrollBoxObject = scrollbox.boxObject.QueryInterface(Components.interfaces.nsIScrollBoxObject);

This regression is probably caused by Bug 979835. See Bug 1083793 for similar issue in Thunderbird.
Marking dependencies as its entirely possible this bug will be fixed by bug 1083793 or its outcome.
Depends on: 1083793
No, it won't be.  You just need to remove the QI here.  BoxObject comes with it's other interfaces already exposed now.
No longer depends on: 1083793
Ah, thanks for the hint! Stefan, can you whip up the patch? rs=me since it sounds fairly simple.
(Assignee)

Comment 4

3 years ago
Created attachment 8507122 [details] [diff] [review]
1084474-remove-QI-nsIScrollBoxObject.diff

Here is a patch.

You might want to check if the comment at https://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-multiday-view.xml#2225 is still valid after the BoxObject changes.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #8507122 - Flags: review?
(Assignee)

Updated

3 years ago
Blocks: 979835
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Updated

3 years ago
Attachment #8507122 - Flags: review? → review?(philipp)

Updated

3 years ago
Keywords: regression
Comment on attachment 8507122 [details] [diff] [review]
1084474-remove-QI-nsIScrollBoxObject.diff

Review of attachment 8507122 [details] [diff] [review]:
-----------------------------------------------------------------

> You might want to check if the comment at
> https://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-
> multiday-view.xml#2225 is still valid after the BoxObject changes.

Checked that, the boxObject still doesn't have the scroll* methods.
Attachment #8507122 - Flags: review?(philipp) → review+
Created attachment 8509623 [details] [diff] [review]
Patch for checkin
Attachment #8507122 - Attachment is obsolete: true
Attachment #8509623 - Flags: review+
Keywords: checkin-needed
(Assignee)

Comment 7

3 years ago
Pushed to https://hg.mozilla.org/comm-central/rev/542a534abc0a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 3.8
You need to log in before you can comment on or make changes to this bug.