black background and repeated flashing when rendering map demo

RESOLVED DUPLICATE of bug 1083079

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1083079
4 years ago
4 years ago

People

(Reporter: gal, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox35?)

Details

(URL)

(Reporter)

Description

4 years ago
STR.

1. Go to http://leafletjs.com/index.html
2. Zoom out a bit
3. Zoom in again
4. On gecko the background flashes black and tiles disappear repeatedly.

Expected:

4. On Safari there is no flashing and tiles don't disappear.

Comment 1

4 years ago
This is a severe rendering regression in a widely used JavaScript library; can someone please investigate?

As a starting point, it is almost certainly caused by tiled layers. Disabling layers.enable-tiles in about:config and relaunching Firefox makes the issue disappear.

Comment 2

4 years ago
cc'ing some gfx peeps on this - seems like a pretty serious issue to have crept into a release :/

Apparently fixed on trunk? I have no Mac to test this, so can't confirm.

Comment 3

4 years ago
Confirmed, the issue does not appear in 38.0a1 (2015-01-13).
It also doesn't appear to affect aurora (v36). Perhaps this is caused by the issue that bug 1083079 fixed.

Comment 5

4 years ago
(In reply to Jonathan Watt [:jwatt] from comment #4)
> It also doesn't appear to affect aurora (v36). Perhaps this is caused by the
> issue that bug 1083079 fixed.

Looks like it's the same issue, because this is the same we have in Leaflet:

> it turns out this is because [...] the tiles are at negative offsets.

Any idea on when FF 36 lands to stable?
(In reply to Vladimir Agafonkin from comment #5)
> Any idea on when FF 36 lands to stable?

24th February according to https://wiki.mozilla.org/RapidRelease/Calendar
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083079

Comment 8

4 years ago
Is there any JS or CSS workaround for the issue? It would be a real shame to have all Leaflet maps on the web broken on Mac FF for another month+.
I'm not sure that there is. It's difficult to know when content will trigger this. In a very loose and vague sense it can happen when internally something is layerized and there are negative offsets in some way. I'm not clear on exactly what content will result in negative offsets in the internal code, but things like positioning positioned elements relative to 'bottom' can do it, at least in certain circumstances.
tracking-firefox35: --- → ?
You need to log in before you can comment on or make changes to this bug.