Closed Bug 1085025 Opened 6 years ago Closed 6 years ago

Handle video call error responses

Categories

(Chat Core :: XMPP, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1018060

People

(Reporter: aleth, Unassigned)

References

(Depends on 1 open bug)

Details

e.g. on attempting to call, if we receive in return the following stanza, we currently don't disconnect immediately:

received:
<iq xmlns="jabber:client" id="15" type="error" to="aleth@s/Instantbird-Dev" from="cp@gmail.com">
 <jingle xmlns="urn:xmpp:jingle:1" initiator="aleth@s/Instantbird-Dev" action="session-initiate" sid="8995125d-550b-3645-a53e-a79259348b76">
  <content xmlns="urn:xmpp:jingle:1" creator="initiator" name="voice">
   <description xmlns="urn:xmpp:jingle:apps:rtp:1" setup="actpass" media="audio">
    <payload-type xmlns="urn:xmpp:jingle:apps:rtp:1" name="opus" clockrate="48000" id="109" channels="2">
     <parameter xmlns="urn:xmpp:jingle:apps:rtp:1" ptime="20"/>
    </payload-type>
    <payload-type xmlns="urn:xmpp:jingle:apps:rtp:1" id="9" name="G722" clockrate="8000"/>
    <payload-type xmlns="urn:xmpp:jingle:apps:rtp:1" id="0" name="PCMU" clockrate="8000"/>
    <payload-type xmlns="urn:xmpp:jingle:apps:rtp:1" id="8" name="PCMA" clockrate="8000"/>
    <payload-type xmlns="urn:xmpp:jingle:apps:rtp:1" id="101" name="telephone-event" clockrate="8000">
     <parameter xmlns="urn:xmpp:jingle:apps:rtp:1" value="0-15"/>
    </payload-type>
    <rtp-hdrext xmlns="urn:xmpp:jingle:apps:rtp:rtp-hdrext:0" id="1" uri="urn:ietf:params:rtp-hdrext:ssrc-audio-level"/>
   </description>
   <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="bb5b3c66" pwd="ae21c9b15a5e153e8385b725e2c81482">
    <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256">
     78:6A:F5:5D:34:89:4D:89:95:7A:2D:59:39:0B:22:4A:20:D3:E3:BD:5A:24:09:C8:21:13:DF:D2:D2:74:F9:5C
    </fingerprint>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" component="0" port="62177" foundation="1" type="host" priority="2130444543" protocol="UDP" ip="192.168.1.5"/>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" component="0" port="54162" foundation="2" type="host" priority="2130444542" protocol="UDP" ip="192.168.1.5"/>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" relport="62177" type="srflx" protocol="UDP" ip="151.49.224.124" component="1" port="62177" foundation="1" reladdr="192.168.1.5" priority="1694302207"/>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" relport="54162" type="srflx" protocol="UDP" ip="151.49.224.124" component="1" port="54162" foundation="2" reladdr="192.168.1.5" priority="1694302206"/>
   </transport>
  </content>
  <content xmlns="urn:xmpp:jingle:1" creator="initiator" name="face">
   <description xmlns="urn:xmpp:jingle:apps:rtp:1" setup="actpass" media="video">
    <payload-type xmlns="urn:xmpp:jingle:apps:rtp:1" id="120" name="VP8" clockrate="90000">
     <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="nack"/>
     <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="nack" subtype="pli"/>
     <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="ccm" subtype="fir"/>
    </payload-type>
   </description>
   <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="bb5b3c66" pwd="ae21c9b15a5e153e8385b725e2c81482">
    <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256">
     78:6A:F5:5D:34:89:4D:89:95:7A:2D:59:39:0B:22:4A:20:D3:E3:BD:5A:24:09:C8:21:13:DF:D2:D2:74:F9:5C
    </fingerprint>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" component="0" port="60060" foundation="1" type="host" priority="2130444543" protocol="UDP" ip="192.168.1.5"/>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" component="0" port="51226" foundation="2" type="host" priority="2130444542" protocol="UDP" ip="192.168.1.5"/>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" relport="60060" type="srflx" protocol="UDP" ip="151.49.224.124" component="1" port="60060" foundation="1" reladdr="192.168.1.5" priority="1694302207"/>
    <candidate xmlns="urn:xmpp:jingle:transports:ice-udp:1" relport="51226" type="srflx" protocol="UDP" ip="151.49.224.124" component="1" port="51226" foundation="2" reladdr="192.168.1.5" priority="1694302206"/>
   </transport>
  </content>
 </jingle>
 <error xmlns="jabber:client" type="cancel" code="501">
  <feature-not-implemented xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/>
 </error>
</iq>
It seems better to do this straight in bug 1018060.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1018060
You need to log in before you can comment on or make changes to this bug.