Toolbar buttons lacks label margins

RESOLVED FIXED in seamonkey2.33

Status

SeaMonkey
Themes
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: stefanh, Assigned: stefanh)

Tracking

({regression})

Trunk
seamonkey2.33
x86
Mac OS X
regression

SeaMonkey Tracking Flags

(seamonkey2.30 wontfix, seamonkey2.31 fixed, seamonkey2.32 fixed, seamonkey2.33 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
https://hg.mozilla.org/mozilla-central/rev/e2b3ecf5916b from bug 1001871 introduced this change in toolbarbutton.css:

 .toolbarbutton-text {
-  margin: 0px;
+  margin: 0 !important; /* !important for overriding global.css */

This mean that any .toolbarbutton-text margin rule not having an !important will get overridden by the above rule. Also, the .toolbarbutton-text margin was over-ruled by the label margin rules in global.css before this change. Iotw, our large toolbar button now lacks label margins.

This can easily be seen in the PT and the main toolbars. For example, in the PT there's no space between the folder icon and the label.
(Assignee)

Updated

4 years ago
status-seamonkey2.30: --- → affected
status-seamonkey2.31: --- → affected
status-seamonkey2.32: --- → affected
status-seamonkey2.33: --- → affected
(Assignee)

Comment 1

4 years ago
I'm going to put up a quick fix for aurora/beta... but I think it might be worth improving the current look a bit.
Keywords: regression
(Assignee)

Comment 2

4 years ago
Created attachment 8507521 [details] [diff] [review]
Restore margins

Too bad I didn't noticed this before... this will restore the margins. As I said, there is room for improvement, but it might be better to do that in a separate bug.
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #8507521 - Flags: review?(mnyromyr)

Comment 3

4 years ago
Hmm why did they touch the theme files in toolkit if bug 1001871 is Firefox specific?

Updated

4 years ago
Attachment #8507521 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 4

4 years ago
Comment on attachment 8507521 [details] [diff] [review]
Restore margins

[Approval Request Comment]
Regression caused by bug 1001871
User impact if declined: no margin between folders and labels in PT, not enough distance between nav-bar toolbarbuttons.
Testing completed (on m-c, etc.): Nope, but the fix is obvious
Risk to taking this patch (and alternatives if risky): Very low, it just restores previous behaviour
String changes made by this patch: none
Attachment #8507521 - Flags: approval-comm-beta?
Attachment #8507521 - Flags: approval-comm-aurora?
(Assignee)

Comment 5

4 years ago
http://hg.mozilla.org/comm-central/rev/50dd9f50d92b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.33: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.33

Updated

4 years ago
Attachment #8507521 - Flags: approval-comm-beta?
Attachment #8507521 - Flags: approval-comm-beta+
Attachment #8507521 - Flags: approval-comm-aurora?
Attachment #8507521 - Flags: approval-comm-aurora+
(Assignee)

Comment 6

4 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/dc183e0df1fc
http://hg.mozilla.org/releases/comm-beta/rev/02b8a1d209a1
status-seamonkey2.30: affected → wontfix
status-seamonkey2.31: affected → fixed
status-seamonkey2.32: affected → fixed
You need to log in before you can comment on or make changes to this bug.