Open Bug 1085098 Opened 8 years ago Updated 6 years ago

Version # in "About Nightly" is incorrect

Categories

(Firefox :: General, defect)

35 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

UNCONFIRMED

People

(Reporter: grgoffe, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140517030204

Steps to reproduce:

I would expect the correct version of FF Nightly to be displayed. The "About Nightly" pulldown should have an "Update Now" button.


Actual results:

see above


Expected results:

I would expect the correct version of FF Nightly to be displayed. The "About Nightly" pulldown should have an "Update Now" button.

FF Nightly is not detecting the correct version # gathered automatically(?) by this URL.
Notice the "User Agent" above is displaying 32.0 and NOT 35.
On which channel are you? Nightly?
If you create a new profile and you force the update, does it work?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Loic,

Thanks for your response to this bug.

I am in deed on the Nightly channel. I just started my nightly with the -p option. Only the Default User appeared. I created a new profile. How do I force an update? The "About" in "Help" used to have a "Check for updates" button... not anymore apparently.

The browser came up and in a few minutes I got a popup from my OS I think that said updates are available, then nothing else. I restarted, expecting the updates to be procured and applied but so far, nothing. Updates are allowed in this user's profile. No other popups have appeared. My "About Nightly" claims the update version is currently at 32.0a1 (2014-05-17). It's the 20th here... (USA, California).

Ideas?

George...
Several manual updates later, the hang(?) in updating is still failing.
Hi George,

have you tried to uninstall and install an actual nightly from zerro?
maybe one of the last updates had this problem - some times this happens to me also.
Stefan,

Thanks for your response.

I have done this but haven't checked the "About" release #. I've been having trouble with the update failing... I get the popup requesting permission which I give... then it just sits there with the slider moving back and forth... I've started the update and then gone to bed... wake up the next morning with the same popup and same behavior. 

Workarounds are great but my objective is to report bugs I encounter during "normal" "customer" type interactions. I really like some of the features in the current nightly... like multi-threading.

George...
Stefan,

My current "About" Version # is 32.0a1 (2014-05-17). Hmmmmm. What's wrong with this picture?

George...
Hello George,

I just installed an new downloaded nightly and I get it correct.
can you please give me the information, from where you download your copy of nightly?

was it:
https://nightly.mozilla.org/
Duplicate of this bug: 1085056
Stefan,

I just did a complete re-install from the latest 64bit tar.bz2 file on the nightly.mozilla.org site. The "About" version is still 32.0a1 (2014-05-17).

George...
Check with a process monitoring tool if you don't have another Firefox process running in background
Paul,

Thanks for your response.

I run FF the released version and FF nightly from different userids with different .mozilla directories. Is that enough to ensure that there are "no other instances" of FF for the purposes of update?

George...
George,

Close all your Firefox windows, then open a terminal and run:
ps -U <yourusername> | grep "firefox"
What's your result?

Now install latest nightly as follows:
1. Download http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-36.0a1.en-US.linux-x86_64.tar.bz2
2. Right click on the archive / extract here (now my nightly will be in ~/Downloads/firefox/)
3. Open a new terminal
4. cd ~/Downloads/firefox/
5. ./firefox -no-remote -P
6. create new profile and start nightly
7. go to Help/About Nightly
What do you see now?
Flags: needinfo?(grgoffe)
Paul,

Here you go. What's next?

I was thinking that it might be a good idea to give more information when an error occurs or when update is in progress.

Regards,

George...

ps -U grgoffe
  PID TTY          TIME CMD
21562 pts/48   00:00:00 bash
29958 pts/47   00:00:00 dbus-launch
29959 ?        00:00:00 dbus-daemon
29961 ?        00:00:00 gconfd-2
Flags: needinfo?(grgoffe)
I'm including two file taken during the failure. I was running ff-nightly and it detected that an update was available and put up a pop-up. I let the update proceed. The pop-up said "Connecting to server"... for > 30 minutes...

I attached strace with -xvfp <pid of ff-nightly> and then attached gdb with gdp -p <pid of ff-nightly>. Both files are included here. The strace showed a lot of FUTEX system calls and some "Resource not available" messages. When I attached gdb I got a lot of messages complaining about debuginfo missing and displayed a yum command to do some updates. This command got a file not found message.

NO OTHER Firefox was running as ps -U grgoffe showed.

George...
Component: Untriaged → Application Update
Product: Firefox → Toolkit
Paul,

Is anyone working this bug? I see nothing has changed in the behavior of Firefox-nightly even though I have manually updated as of yesterday's nightly build.

Regards,

George...
Gijs, can you also take a look please ?
Flags: needinfo?(gijskruitbosch+bugs)
Paul,

I have new info on this bug. I ran strace against FF-nightly after I got the update popup... Looking for possible errors or files being opened.

In my nightly setup I have a specific userid that I use to test. I made an "opt" directory in that user's home directory. This is where I installed Firefox-Nightly. The "real" "opt" has the same directory and filenames as this "~grgoffe/opt" directory. I found that Firefox-Nightly was referencing "/opt/firefox-nightly" instead of "~grgoffe/opt/firefox-nightly". The "/opt" version has the build info of "32.0a1 (2014-05-17)"! So, first bug solved and possibly the second one too? I removed the firefox-nightly directory in "/opt" and restarted firefox-nightly from grgoffe. The about info now says "36.0a1 (2014-11-17)". The correct info. Additionally, this "About" is displaying info that states that the update is being downloaded.

I had thought that the Firefox-nightly that was running would use the directory that it was installed in. Somehow it picked up the "/" and so was using /opt rather than ~grgoffe/opt. Isn't this how FF should be working?

So, now, the manually installed Firefox-Nightly has failed. Here's the last-updated.log:

      1 Performing a staged update
      2 PATCH DIRECTORY /export/home/grgoffe/opt/firefox-nightly/updates/0
      3 INSTALLATION DIRECTORY /export/home/grgoffe/opt/firefox-nightly
      4 WORKING DIRECTORY /export/home/grgoffe/opt/firefox-nightly/updated
      5 ensure_copy: failed to open the file for reading: /export/home/grgoffe/opt/firefox-nightly/lsR, err: 13
      6 failed: 6
      7 calling QuitProgressUI


This file is owned by root since I did an ls -alR > lsR in this install directory. Why is Firefox-Nightly trying to read this file?

I have changed ownership of this file so that update will continue? Succeed? How can I restart the update?

George...
How do you start Firefox?
Flags: needinfo?(gijskruitbosch+bugs)
Gijs,

It's via a "functon" in my bash rc file...

~grgoffe/opt/firefox-nightly/firefox -sync -sync "$*" &

George...
Moving to more correct component since this is the about dialog.
Component: Application Update → General
Product: Toolkit → Firefox
You need to log in before you can comment on or make changes to this bug.