Closed Bug 108533 Opened 23 years ago Closed 21 years ago

IRC URLs never shown as visited in browser

Categories

(Other Applications :: ChatZilla, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: erik, Assigned: rginda)

References

Details

I'm not sure if this is a chatzilla bug, but I'll file it as one anyway.

After having clicked an irc:// url, this url is never shown as visited
(different color) in the browser.

It would be nice if the link did show up as a visited url.
Do mailto: links ever show as visited?
I don't know. I hardly ever click them ;-)

Would be nice and consistent though.
Could this be just a CSS fix?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Remove myself from QA of 33 open Chatzilla bugs and change to default QA
contact, since I have no way to verify these easily.  Still no working Mozilla
on my primary platform and it doesn't look like it will happen anytime soon. :(
QA Contact: mozilla → samuel
my understanding is that certain protocols do not work w/ history, probably
because there is a protocol whitelist for session:history.

recommend resolve/invalid or ->session:history.
Ok, this looks really easy:

client.ghist =
Components.classes["@mozilla.org/browser/global-history;1"].getService(Components.interfaces.nsIGlobalHistory);
client.ghist.addPage("irc://moznet/")

...and it's shown as visited in the browser. :)
Depends on: 229545
Chatzilla 0.9.54 is now available and has landed on the trunk (cvs). This should
have resolved this bug; if it has not, please reopen it.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.