Make bzexport use mozhg's authentication library

RESOLVED DUPLICATE of bug 1033394

Status

Developer Services
Mercurial: bzexport
RESOLVED DUPLICATE of bug 1033394
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1560] )

(Reporter)

Description

4 years ago
The authentication code from bzexport was broken out into mozhg, for Reviewboard.

At the time bzexport wasn't made to use this library, since switching broke a few things & bzexport has no test coverage.

This bug is to make that switch.

Updated

4 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/281]

Updated

4 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/281] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1547] [kanban:engops:https://kanbanize.com/ctrl_board/6/281]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1547] [kanban:engops:https://kanbanize.com/ctrl_board/6/281] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1549] [kanban:engops:https://kanbanize.com/ctrl_board/6/281]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1549] [kanban:engops:https://kanbanize.com/ctrl_board/6/281] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1553] [kanban:engops:https://kanbanize.com/ctrl_board/6/281]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1553] [kanban:engops:https://kanbanize.com/ctrl_board/6/281] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1556] [kanban:engops:https://kanbanize.com/ctrl_board/6/281]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1556] [kanban:engops:https://kanbanize.com/ctrl_board/6/281] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1560] [kanban:engops:https://kanbanize.com/ctrl_board/6/281]
(Assignee)

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1560] [kanban:engops:https://kanbanize.com/ctrl_board/6/281] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1560]
Please fix this. mozhg has supported specifying "userid" and "cookie" in hgrc, which is an extremely important feature on Windows. However bzexport still requires explicit username and password.
(Reporter)

Comment 2

4 years ago
Fixed by the MozReview queue in bug 1033394.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033394
You need to log in before you can comment on or make changes to this bug.