A key's uppercase data is incorrect for layouts that has explicit upperCase mapping

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: timdream, Assigned: mnjul)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
x86
Mac OS X
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed)

Details

(Whiteboard: [p=1])

Attachments

(1 attachment)

STR:

1. Build and switch to Korean layout
2. Hit shift to switch to upper case state.
3. Inspect the key on the top left 

Expected:

1. Should be "ㅃ"

Actual:

1. Character remain "ㅂ"


John, without working on the regression window, you are most likely the offender here. Would you mind check it? Thanks.
Flags: needinfo?(jlu)
This blocks my work on moving the rendering around in bug 1085359.

I can confirm this is a layout normalization issue because this is what app.layoutManager.currentPage.keys[0][0] prints:

{ value: "ㅂ", keyCode: 12610, keyCodeUpper: 12610, lowercaseValue: "ㅂ", uppercaseValue: "ㅂ", isSpecialKey: false }
Blocks: 1085359
On my way. Keeping NI for reminding.
Yeah I found the cause. Patch is on the way.
Assignee: nobody → jlu
Flags: needinfo?(jlu)
Whiteboard: [p=1]
Target Milestone: --- → 2.1 S7 (24Oct)
Created attachment 8508466 [details] [review]
Patch (PR @ GitHub)

The normalization's getUpperCase() looked up upperCase dictionary in a wrong place. It has been fixed.
Attachment #8508466 - Flags: review?(timdream)
Summary: |secondLayout| option has regressed again → A key's uppercase data is incorrect for layouts that has explicit upperCase mapping
Attachment #8508466 - Flags: review?(timdream) → review+
Please point to the regressed bug at the "Blocks" field.
Flags: needinfo?(jlu)
Master: https://github.com/mozilla-b2g/gaia/commit/056edb5bdbf31c3878ee01bdef0a67fa194c100e
Blocks: 1044525
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jlu)
Resolution: --- → FIXED
Blocking 2.2+ for all fixed regressions.
blocking-b2g: 2.2? → 2.2+
Depends on: 1104358
This bug is not fixed on Flame 2.2.

Result: "ㅔ" and "ㅐ" remain on the keyboard when the shift key is pressed.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141121040204
Gaia: e5d666d6f62480ced56c6d9352f5e12befb5a862
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
==============================================================

Filed a new bug 1104358.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][failed-verification]
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
No longer depends on: 1104358
status-b2g-v2.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.