[Loop] Disable button appear in an outgoing call done in an link received in SMS

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lolimartinezcr, Assigned: crdlc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile app][Test-Run1][blocking][tef-triage][patch available][loop approved for 1.1][loop in 1.1])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8507956 [details]
2014-10-20-17-09-37.png

fireE (firee-kk-v2.0-SW2E3-1)
Loop version: 1.1 , 2168965

Prerequisites:
Device A with a link shared by a message received.
Device A logged in Loop application.
Device B logged in Loop application.

STRs:
1. Device A taps in message application and taps in inbox message with link shared.
2. Device A taps in link shared.
3. Device A opens browser and taps in "Start" button -> Outgoing call is done.
4. Device B establishes call.
5. After a few seconds, Device B hangs up call.
6. Device A in "Calls" tab, user can see a new inbox (See attached image:2014-10-20-17-09-37.png) and if user taps long-press about this outgoing call.

Actual result:
A new screen with three posible options is showed: "Disable", "Delete" and "Call". If user taps in "Disable" an error is showed "Oops! That didn't work as expected. Why don't we five it another try?"

Expected result:
Disable button shouldn't appear.
(Reporter)

Updated

4 years ago
Blocks: 1036490
Whiteboard: [Test-Run1] [mobile app]
Just correcting that the "Disable" option should appear but it should work :)

According to the ACs in US bug 1034610, "In the Call Log or in the Shared URL Log, user can long-tap in an item related with a shared URL and the option to “revoke” the URL will be offered. "

The message "Oops! That didn't work as expected. Why don't we give it another try?" should only be shown if there is a server crash when trying to disable a shared URL.

I've retested to confirm that, as Loli has reported,  it's not working and it's not because a server issue because it's working fine if I disable the same URL from the Shared URL tab so there is something wrong in Loop application.
Severity: normal → major
Flags: needinfo?(oteo)
Whiteboard: [Test-Run1] [mobile app] → [mobile app][Test-Run1][blocking][tef-triage]
Just to clarify, when we create the ACs about the URLs revoking from the Call Log and the Shared URL tab, development team advised us that they were two different lists and BBDDs and because time constraint the synchronization between them would be a nice to have but not mandatory. 

Said that, we do not expect that when revoking an URL from the Call log, the corresponding entry in the Shared URL tab changes its status to "Expired"
Flags: needinfo?(oteo)
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
Created attachment 8509583 [details]
Github pull request

Thanks a lot
Attachment #8509583 - Flags: review?(ferjmoreno)
(Assignee)

Comment 4

4 years ago
Created attachment 8509585 [details]
How to show disabled URLs in call log

Thanks
Attachment #8509585 - Flags: ui-review?(vpg)
Comment on attachment 8509585 [details]
How to show disabled URLs in call log

Please use same gray as duration info but text in italic. Thanks!
Attachment #8509585 - Flags: ui-review?(vpg) → ui-review-
(Assignee)

Comment 6

4 years ago
Created attachment 8510075 [details]
Same color and italic
Attachment #8510075 - Flags: ui-review?(vpg)
Attachment #8510075 - Flags: ui-review?(vpg) → ui-review+
Whiteboard: [mobile app][Test-Run1][blocking][tef-triage] → [mobile app][Test-Run1][blocking][tef-triage][patch available]
I have tested Cristian's branch with the patch and it's working perfectly, as it was agreed with Product team in comment 2 (for this v1.1 version). Although a shared URL is deactivated in one of the tabs the rest of entries with that URL will not be updated, it will only be done for each specific entry (even if we have several calls in the Call Log from the same clicked URL).

So giving the approval to land it in 1.1 branch (although it's not landed in master yet) if no mayor issues or changes are raised during the revision.
Whiteboard: [mobile app][Test-Run1][blocking][tef-triage][patch available] → [mobile app][Test-Run1][blocking][tef-triage][patch available][loop approved for 1.1]
Duplicate of this bug: 1087316
Comment on attachment 8509583 [details]
Github pull request

Thanks Cristian!
Attachment #8509583 - Flags: review?(ferjmoreno) → review+
(Assignee)

Comment 10

4 years ago
Merged in master:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/08d2e58b0bf24a97cc209798b8ab40e3842a9786
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

4 years ago
in 1.1:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/c7ba8945df9a3a462bbb543796205b62b29df899
Whiteboard: [mobile app][Test-Run1][blocking][tef-triage][patch available][loop approved for 1.1] → [mobile app][Test-Run1][blocking][tef-triage][patch available][loop approved for 1.1][loop in 1.1]

Comment 12

4 years ago
Disable button is not already appearing in callee device.
Verified on flame:
user.v2.0.184based.B-49.Gecko-675d616.Gaia-2183b4f
eng.v2.0.184based.B-43.Gecko-675d616.Gaia-2183b4f
RAM: 5132M

Loop Version 1.1: ofbfc03
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.