Closed Bug 1085444 Opened 5 years ago Closed 5 years ago

Gecko Profiler broken because it exposes a privileged or cross-origin callable

Categories

(Core :: Gecko Profiler, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: ttaubert, Assigned: bholley)

References

Details

Bug 1082450 seems to have broken the Gecko Profiler add-on. It shows the following error message upon enabling:

Error: Exposing privileged or cross-origin callable is prohibited

Should that rather go to GitHub? I have no idea how we usually handle profiler issues.
Flags: needinfo?(bgirard)
(In reply to Tim Taubert [:ttaubert] from comment #0)
> Bug 1082450 seems to have broken the Gecko Profiler add-on. It shows the
> following error message upon enabling:
> 
> Error: Exposing privileged or cross-origin callable is prohibited
> 
> Should that rather go to GitHub? I have no idea how we usually handle
> profiler issues.

Hm, actually, the Gecko Profiler doesn't appear to used __exposedProps__ at all. What is the file/line reported in the error?
Flags: needinfo?(ttaubert)
The complete error message is:

console.error: geckoprofiler: 
  Message: Error: Exposing privileged or cross-origin callable is prohibited
  Stack:
    injectTimers@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/tim/.mozilla/firefox/0at5j95f.trunk/extensions/jid0-edalmuivkozlouyij0lpdx548bc@jetpack.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:126:1
.inject@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/tim/.mozilla/firefox/0at5j95f.trunk/extensions/jid0-edalmuivkozlouyij0lpdx548bc@jetpack.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:325:5
Flags: needinfo?(ttaubert)
Oh, I see. This is more addon-sdk bustage. I'll fix it.
Assignee: nobody → bobbyholley
Flags: needinfo?(bgirard)
Hm, I can't reproduce. I installed the latest profiler on a local OSX debug build. Can you give me further instructions?

Also, are you running a build with bug 1084385 in it? Looks like that was just merged to m-c a few hours.
Flags: needinfo?(ttaubert)
This was trivial for me to reproduce on last Thursday's Nightly, but I can't reproduce it on today's.
(In reply to Bobby Holley (:bholley) from comment #4)
> Also, are you running a build with bug 1084385 in it? Looks like that was
> just merged to m-c a few hours.

Ah, nice. Building currently.
Let me know if I need to make any updates to the profiler XPI.
Working nicely now with fx-team tip which contains all of m-c. Sorry for the noise!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(ttaubert)
Resolution: --- → INVALID
Blocks: 1077652
You need to log in before you can comment on or make changes to this bug.