Closed Bug 1085672 Opened 8 years ago Closed 8 years ago

Unable to reconnect on IRC

Categories

(Chat Core :: IRC, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: JoeS1, Unassigned)

Details

Attachments

(1 file)

Attached file connect.txt
System Details:
This only seems to happen on my "Performance challenged" work laptop although that's the only system that I get disconnected at all.
I can get disconnected on high swap file usage, or even when my AV is updating.

One thing I noticed in the logs is "Nick already in use"
When I connect initially, my nick shows as JoeS1

Perhaps the fix would be to modify my account info to JoeS1 rather than current JoeS, but I'm sure there are others in the same boat.

I'm using trunk TB from 20140716030206
Also an example of bug 1059290, though that seems unrelated.
Component: Instant Messaging → IRC
Product: Thunderbird → Chat Core
Version: Trunk → trunk
It looks to me like we never try to reset the nick after receiving the error message? I'm unsure of exactly why this would be though. [1] should call [2] which should provide an updated nick. The amount of logging in that function is a little disappointing. It looks like [3] is the only place it can return early and not log anything. JoeS, do you see the message "Could not use the specified nickname. Your nick remains JoeS." (or something like that) in your open conversations?

Note that this code isn't really identical to what's being run as bug 955677 was checked in on August 26. This code was pretty heavily modified, it could be worth trying a more up-to-date version. (I'm personally running Daily 2014-10-15.)

I'll try to reproduce this soon by messing with my network.

[1] https://mxr.mozilla.org/comm-central/source/chat/protocols/irc/ircBase.jsm#1228
[2] https://mxr.mozilla.org/comm-central/source/chat/protocols/irc/irc.js#1196
[3] https://mxr.mozilla.org/comm-central/source/chat/protocols/irc/irc.js#1263
(In reply to Patrick Cloke [:clokep] from comment #2)
> It looks to me like we never try to reset the nick after receiving the error
> message? I'm unsure of exactly why this would be though. [1] should call [2]
> which should provide an updated nick. The amount of logging in that function
> is a little disappointing. It looks like [3] is the only place it can return
> early and not log anything. JoeS, do you see the message "Could not use the
> specified nickname. Your nick remains JoeS." (or something like that) in
> your open conversations?

Nope. No message, just fails to reconnect
Does this still happen with a current nightly? There have recently been some changes in this area.
Flags: needinfo?(jsabash)
Steps:
Shut off wifi to force disconnect
Turned back on after disconnected IRC

Checked status
Didn't see an automatic connection attempt, however did reconnect successfully with a manual try.

This wasn't possible at the time of the bug filing.
So WFM or whatever bug you would like to cite.

Thanks
Flags: needinfo?(jsabash)
(In reply to Joe Sabash [:JoeS1] from comment #5)
> Checked status
> Didn't see an automatic connection attempt, however did reconnect
> successfully with a manual try.
> 
> This wasn't possible at the time of the bug filing.
> So WFM or whatever bug you would like to cite.

That's good news, thanks!

By the way, the account manager should show you if there is a reconnect attempt pending or not. It tries periodically, as you will see...
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.