If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Plug-In Not Loaded" requester not localizable

VERIFIED WONTFIX

Status

()

Core
Plug-ins
VERIFIED WONTFIX
16 years ago
15 years ago

People

(Reporter: Yuying Long, Assigned: av (gone))

Tracking

({l12y})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This bug is from bugscape 8238 which is still existing in N6.2-Ja builds:
http://bugscape.netscape.com/show_bug.cgi?id=8238

From original report:
----------------------------------
Steps:
* start N6.1b1 (20010607)
* ensure no quicktime plug-in is installed
* open any page including a quicktime movie (e.g.
http://www.exploratorium.edu/eclipse/why_mov.html )
* requester pops up in english, should be Japanese

Note: This is also seen in DE build (see bugscape 6764)

This is a show stopper for JA and needs to be localized.
(Reporter)

Updated

16 years ago
Keywords: l12y
(Reporter)

Comment 1

16 years ago
Nominate it as nsbeta1.

Keywords: nsbeta1

Comment 2

16 years ago
*** Bug 94196 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
This is currently not possible because the "Default Plugin" does not have access
browser string bundles. However, the problem will be solved when the current
"Default Plugin" is removed in bug 83754 (helpwanted). It's functions will be
brought into the browser and UI will use string bundles and XUL.
Depends on: 83754

Comment 4

16 years ago
Yuying, 

This bug goes away with bug 83754 .  So when you do Japanese builds, please
localize the XBL dialog!  Marking nsbeta1- per ADT triage.
Keywords: nsbeta1 → nsbeta1-

Comment 5

16 years ago
CC to yxia and rchen.

Comment 6

16 years ago
Remember in NS6.x, those strings in "npnul32.dll"(for Win32) and "Default 
Plug-in"(for Mac) were not localizable. It will show garbled characters if we 
localize them into Japanese. So we had to keep them in English.

Comment 7

15 years ago
The plug-ins triage team (av, beppe, peterl, serge and shrir) have reviewed this
issue and have made the following determination:

This can be resolved after bug 106413 is resolved. In the current state, the
plug-in cannot be localized.

Note, that the current default plug-in will not able to be fixed, the resolution
for bug 106413 is to replace the current default plug-in and that one will be
localizable. COnsequently, we are marking this bug as won't fix in lieu of bug
106413
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 8

15 years ago
.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.