[rfe] UI for configurable Backspace behavior

VERIFIED DUPLICATE of bug 57805

Status

()

Core
Keyboard: Navigation
--
enhancement
VERIFIED DUPLICATE of bug 57805
16 years ago
8 years ago

People

(Reporter: otto, Assigned: Aaron Leventhal)

Tracking

(Depends on: 1 bug)

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
It appears that opinions differ on what the proper behavior of the Backspace key
should be (personally, I prefer Previous Page), so perhaps it should be a user
option:

O  Page Up
O  Go Back
O  Do Nothing

Comment 1

16 years ago
i thought users could already do this w/ some profile file
(Assignee)

Comment 2

16 years ago
Timeless, most real users don't want to edit a .js or .xml file! lol
Summary: [rfe] Configurable Backspace behavior → [rfe] UI for configurable Backspace behavior
confirming rfe.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
Reporter: there was talk about creating general keyboard configurability at some
point. That would allow users to assign they keystrokes to whatever
functionality they like. Should this bug be subsumed by that?

Comment 5

16 years ago
See http://www.mozilla.org/unix/customizing.html#keys for information on how to
set up custom key bindings.  It only works for commands which are exposed to
XBL, but page up/down are selection commands so they are exposed (see the editor
bindings in htmlBindings.xml for the commands to use).

Comment 6

16 years ago
Bug 57805 is the one for a general key remapping UI.  It's helpwanted, and isn't
likely to get fixed any time soon unless someone contributes a fix or at least a
start on one.
Depends on: 57805
(Assignee)

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 57805 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED

Comment 9

8 years ago
I am not sure, if it was a good idea to mark this feature request as duplicate to 57805.
It is probably much easier to enable configuring just one key in the user interface than creating a user interface for configuring all or most of the keys.

There has been many discussions about the backspace behaviour in firefox on linux. I know, that it can be configured in "about:config", but this not convinient and absolutely not obvious to linux-newbees.

Linux should be a real alternative to Windows. Now, that firefox has got so popular, and internet gets more and more important, sometimes even replacing desktop-functionality, people can think of switching to linux. Let's make the switch as easy and comfortable as possible.
You need to log in before you can comment on or make changes to this bug.