(Prosieben.de) videoplayer broken in Firefox for Android

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: kerstin.vonroenn, Unassigned)

Tracking

Firefox 33
Other
Android

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form] [country-de] [video] , URL)

(Reporter)

Description

3 years ago
Site: http://www.prosieben.de/stars/red/video/voice-dreamteam-samu-haber-und-rea-garvey-clip
I can't watch the video on this page

:: Steps To Reproduce

Just call the web page

:: Expected Result

The video should be shown

:: Actual Result

The video won't be shown

:: Additional Information

Software Version: 33.0
Device Information: Galaxy Note 3
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
(Reporter)

Updated

3 years ago
Component: Mobile → General
Product: Tech Evangelism → Firefox for Android
Version: unspecified → Firefox 33
I spy a bunch of JS Errors in console when loading the page in Firefox for Android. 

Probably the big one related to (below) which throws other things off

W/GeckoConsole(13306): [JavaScript Error: "TypeError: st is undefined" {file: "http://secure-eu.imrworldwide.com/novms/js/2/ggcmb390.js" line: 1}]
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism

Updated

3 years ago
Summary: I can't watch the video on this page → (Posiben.de) videplayer broken in Firefox for Android
(Reporter)

Updated

3 years ago
Summary: (Posiben.de) videplayer broken in Firefox for Android → (Prosieben.de) videoplayer broken in Firefox for Android

Updated

3 years ago
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-de] [video]

Comment 2

3 years ago
Yes I see the same error.

aW and aZ are defined earlier as 
var Aw;
var Ax;


  function M(name, cora) {
    var st;
    if (cora == 1) st = aW;
     else st = aX;
    var r = - 1;
    var K = - 1;
    r = st.indexOf('<' + name + '>');
    if (r >= 0) {
      r += name.length + 2;
      K = st.indexOf('</' + name + '>', r);
    }
    if (r >= 0 && K > r) return st.substring(r, K);
    return null;
  };

cora == 0
so st = aX which is undefined.
name = 'censuscategory'

indexOf on something which is undefined can't work. So there is something happening before.

Maybe happening in 

      case 15:
        intCount = 0;
        dr = 0;
        if (f == 'preroll' || f == 'postroll' || f == 'midroll' || f == 'ad') {
          i = 1;
          aW = l;
        } else {
          i = 0;
          aX = l;
        }
        videoType = f;
        bV = i;
        o = i;
        bf(i);
        if (functionType == 15) {
          cU['CS'][i] = 1;
          playState = 1;
        }
        var H = unescape(M('length', bV));
        if (H != null && !isNaN(H)) H = Number(H);
         else H = 30;
        cU['VL'][bV] = H;
        var tit = M('title', bV);
        if (tit != null && tit != '') cU['Title'][bV] = tit;
         else cU['Title'][bV] = d;
        if (bV == 0) ba();
        L = 0;
        cU['SS'][bV] = L;
        dn(i, d, f, j, k);
        ds(i, d, f, j, k);
        break;


"1413979091733,15,de-505813_b03_574154181,ad,<censuscategory>red!</censuscategory><category>stars</category><length>13</length><livestream>no</livestream><subcategory>red</subcategory><title>574154181</title><uurl>de-505813_b03_574154181</uurl><vidtype>ad</vidtype><nol_c2>p2,N</nol_c2><nol_c5>p5,http://www.prosieben.de/stars/red/video/voice-dreamteam-samu-haber-und-rea-garvey-clip</nol_c5><nol_c8>p8,13</nol_c8><nol_c10>p10,www.prosieben.de</nol_c10><nol_c12>p12,Werbung</nol_c12><nol_c16>p16,dVxRcCpOqKyFz03star</nol_c16><nol_c18>p18,N</nol_c18><nol_c11>p11,de-505813_b03_574154181</nol_c11><nol_c17>p17,preroll</nol_c17>,1"

But I'm not even sure that is the reason. 
The ads play well, but then when it's time to play the main video, it doesn't start.
This doesn't work in Chrome for Android either.
(Haven't re-tested, but if this is still broken we could "move" it to webcompat.com)
looking again at that code it looks more like stats script than something powering the video.. I get stuff that looks like desktop content though. If the site has decided to not do a mobile version there's not much we can do about that..

Comment 6

2 years ago
On Firefox Android we receive a mobile version with android version mumber in the UA.
http://www.prosieben.de/stars/red/video/voice-dreamteam-samu-haber-und-rea-garvey-clip

The script for the video player is at:
http://is.myvideo.de/player/kolibri/2.3.0/psd/prod/kolibri.js
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can't even test this from Norway now, it says (in Chrome) that the video is not available in my country..
We need someone in Germany to test these. 
I tried in Japan and it doesn't work be on Chrome or Firefox.
(Reporter)

Comment 9

a year ago
It's working now.The Bug can be closed
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.