Closed Bug 1087122 Opened 5 years ago Closed 5 years ago

Make it possible to open printing dialogs from the content process

Categories

(Core :: DOM: Content Processes, defect)

32 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1082579
Tracking Status
e10s m3+ ---

People

(Reporter: mconley, Assigned: mconley)

References

Details

Windows and Linux both open dialogs (either XUL dialogs, or OS-specific dialogs) for printing. Unfortunately, the opening of those dialogs is tied in pretty tightly with the print engine that runs in the content process.

Luckily, it's possible to plug in replacement components to provide those dialogs. I think it should be possible to proxy the requests to open dialogs from the content process to the parent process. That's not the hard part - the hard part will be sending back the information from those dialogs back to the content process in a meaningful way to kick off the print jobs.
I can't believe I just duped myself.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1082579
You need to log in before you can comment on or make changes to this bug.