bug 1084367 disabled many MSE tests

RESOLVED FIXED in mozilla36

Status

P5
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: karlt, Assigned: karlt)

Tracking

(Blocks: 1 bug)

unspecified
mozilla36
x86_64
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

This wasn't intentional; it must have been a merge error on my part.
Although I'm confused; bug 1066467 makes it look like you intentionally disabled these tests?
Yeah, so this was a merge error. For tedious reasons I have to run the updates on cedar rather than try, and it got behind m-c. I'm waiting for some try results to reenable the tests.
Created attachment 8511104 [details] [diff] [review]
Reenable MSE tests accidentially disabled in last update.

I think this is the right set of tests. Expected results set based on a Try run, but please verify that these match what you expect. I wonder if the ones which are different between Linux and Linux 64 are actually unstable?
Attachment #8511104 - Flags: review?(karlt)
(Assignee)

Comment 5

4 years ago
Comment on attachment 8511104 [details] [diff] [review]
Reenable MSE tests accidentially disabled in last update.

(In reply to James Graham [:jgraham] from comment #4)
> I wonder if the
> ones which are different between Linux and Linux 64 are actually unstable?

Yes, there are some that are not stable yet, and so should not be enabled.

Let's focus here on reverting the accidental changes from bug 1087165.
Attachment #8511104 - Attachment is obsolete: true
Attachment #8511104 - Flags: review?(karlt)
(Assignee)

Comment 6

4 years ago
c27a4a16bf74 didn't change any media-source tests, so expected results should be the same.  I ran hg revert -r c27a4a16bf74\^ testing/web-platform/meta/media-source

Like attachment 8511104 [details] [diff] [review], this reverts the change for NT 5.1.2600, which didn't seem related to the pull from upstream.

https://hg.mozilla.org/integration/mozilla-inbound/rev/bfa9cf004a66

I expect [Test appendBuffer completes previous seek to truncated duration] and
[Test seeking beyond media duration.] are probably still unstable.

I couldn't reproduce the 32-bit failure recorded in attachment 8511104 [details] [diff] [review] for mediasource-config-change-webm-a-bitrate.html.
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=a4a14559fb26
Priority: -- → P5
(Assignee)

Comment 7

4 years ago
https://hg.mozilla.org/mozilla-central/rev/bfa9cf004a66
Assignee: nobody → karlt
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.