Send Page & Send Link should use the compose service

VERIFIED FIXED in mozilla0.9.7

Status

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Trunk
mozilla0.9.7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Have fix)

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
Currently, the send page and send link function are not using the compose
service to open the compose window but rather open the chrome directly. They
should use the compose service in order to be able to use the recycled compose
window.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: Have fix
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 1

17 years ago
Created attachment 56766 [details] [diff] [review]
patch for mozilla/mailnews, v1
(Assignee)

Comment 2

17 years ago
Created attachment 56767 [details] [diff] [review]
patch for mozilla/editor, v1
(Assignee)

Updated

17 years ago
Attachment #56766 - Attachment description: patch for mozilla\mailnews, v1 → patch for mozilla/mailnews, v1

Updated

17 years ago
Keywords: nsbeta1+

Comment 3

17 years ago
r=varada
(Assignee)

Comment 4

17 years ago
Comment on attachment 56766 [details] [diff] [review]
patch for mozilla/mailnews, v1

R=varada
Attachment #56766 - Flags: review+
(Assignee)

Comment 5

17 years ago
Comment on attachment 56767 [details] [diff] [review]
patch for mozilla/editor, v1

R=ducarroz
Attachment #56767 - Flags: review+

Comment 6

17 years ago
Comment on attachment 56766 [details] [diff] [review]
patch for mozilla/mailnews, v1

sr=mscott
Attachment #56766 - Flags: superreview+
(Assignee)

Comment 7

17 years ago
Fixed and checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

17 years ago
QA Contact: sheelar → stephend
OS: Windows 2000 → All
Hardware: PC → All
Using user_pref("mail.compose.max_recycled_windows", 1); I was able to see the
difference in speed between the 1st window and the 2nd window (almost instant),
and was able to Send Page and Send Link correctly using builds:

2001-11-20-08 Mac OS 9.1
2001-11-22-08 RedHat 7.2
Latest Windows 2000 cvs trunk

Verified FIXED.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.