Closed Bug 1087484 Opened 8 years ago Closed 8 years ago

[Window Management] Going to card view right after opening the camera app leads to a non functional shutter button

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1087475
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: KTucker, Unassigned)

References

()

Details

(Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(1 file)

Description:
If the user opens the camera app, goes into card view immediately and goes back into the camera app, the shutter button will not function. Instead, the focus circles will keep appearing behind the button when tapped.

Repro Steps:
1)  Updated Flame to Build ID: 20141022001201
2)  Open the camera app and immediately hold down the home button to enter card view.
3)  Tap on the camera app to go back into it from card view. 
4)  Tap on the shutter button to take a picture.

Actual:
The camera focus circles will appear behind the shutter button every time the user taps on the shutter button instead of taking a picture.

Expected:
The camera takes a picture when the shutter button is pressed.

Environmental Variables
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141022001201
Gaia: 3d9cc667f4e929861a9a77c41096bbf5a9c1bde0
Gecko: 928b18f7d8ff
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
Repro frequency: 100%
See attached: Logcat, Video
Youtube: http://youtu.be/sq5Zvt4SYTg
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][systemsfe]
This issue also occurs on the Flame 2.2(319mb)(KK)(Full Flash)

The camera button will not function correctly after opening the camera app, going into card view immediately and then going back into camera. Focus circles will appear behind the shutter button when tapped.

Flame 2.2 

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141022040201
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: ae4d9b4ff2ee
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

--------------------------------------------------------------------------

I cannot reproduce this issue on the Flame 2.0(319mb)(KK)(Full Flash) because a different issue occurs.

The user will encounter a black screen when they open the camera app,goes into card view and then goes back into the camera app.

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141022000201
Gaia: 812ae91c9708a9116cdb2d15cc02a43ded862a78
Gecko: f92e54a91038
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
[Blocking Requested - why for this release]:
Severe functional issue with a core feature.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Broken functionality.
blocking-b2g: 2.1? → 2.1+
I cant reproduce this exactly. My first attempt with browser, settings and FM radio apps running I launched camera (ok'd the location prompt), long-tapped home button to show task manager, tap camera card and the camera app shows loading spinner and stuck there. On the 2nd attempt, all worked as expected. 

2.1 changed what happens when task-manager/cards-view shows: In <= 2.0 we used to open and switch the active app to be the homescreen. In 2.1 we close the active app, but do *not* open the homescreen. My hunch is this bug is linked to that.
Marking as a duplicate of Bug 1087475 since there is already ongoing investigation happening there.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1087475
I just want to make sure that my bug was clear. 

The camera viewfinder shows as expected for me when encountering my issue. The camera "Focus" circles are appearing behind the shutter button when the user taps on it. This is very timing specific. You have to tap on the camera icon and then immediately hold the home button to enter card view and then tap on the camera card to go back into camera. I was able to reproduce this 100% on today's Flame 2.1 build.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-----------------------------------------------------------------------------

The other issue this has been duped to is the infinite blue "spinner" icon that stays on the screen when the viewfinder is not loaded at all. 

Just making a note to myself here to watch this issue in case the fix for bug 1087475 does not resolve my issue.
Flags: needinfo?(ktucker)
> The camera viewfinder shows as expected for me when encountering my issue.
> The camera "Focus" circles are appearing behind the shutter button when the
> user taps on it. This is very timing specific. You have to tap on the camera
> icon and then immediately hold the home button to enter card view and then
> tap on the camera card to go back into camera. I was able to reproduce this
> 100% on today's Flame 2.1 build.

OK yeah I was just able to reproduce this also, by waiting until the shutter button appears (fraction of a second) before long-tapping home. They do both seem like symptoms of the same problem though - Camera is still initializing when it is closed by task manager. Lets watch this space (or bug 1087475)
Sounds good. Thank you Sam.
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.